1. #1
    Sencha Premium Member
    Join Date
    Jun 2011
    Location
    Nottingham, UK
    Posts
    24
    Vote Rating
    0
    mysterydiner is on a distinguished road

      0  

    Default Unanswered: AjaxProxy fails to load data when offline ad cached - is there a work around

    Unanswered: AjaxProxy fails to load data when offline ad cached - is there a work around


    I'm using the html 5 cache to go offline with my Sencha Touch app.
    Sencha mostly works fine - but I have found that The AjaxProxy fails reading cached json files when the server is offline even though these are specified in the cache.manfiest.
    I know the HTML5 cache works with the ajax calls made with the standard XMLHttp object - but the http response codes in the callbacks are a bit dodgy.

    Is there a work around for this? - is this a bug?
    Any help or advice would be greatly appreciated.

    regards

    Tom

  2. #2
    Sencha User blakdronzer's Avatar
    Join Date
    Jan 2011
    Location
    Mumbai, India
    Posts
    27
    Answers
    3
    Vote Rating
    0
    blakdronzer is on a distinguished road

      0  

    Default


    Hi there,

    May be this should throw some light to you.

    http://www.sencha.com/learn/taking-s...-apps-offline/

  3. #3
    Sencha Premium Member
    Join Date
    Jun 2011
    Location
    Nottingham, UK
    Posts
    24
    Vote Rating
    0
    mysterydiner is on a distinguished road

      0  

    Default Specifically AjaxProxy in Sencha 2 loading from cached manifest

    Specifically AjaxProxy in Sencha 2 loading from cached manifest


    Thanks blakdronzer for your suggestions. I am already using local storage succesfully for offline apps.
    In this particular instance i can't use the local storage as the data is already in a json file.
    My question is specifically how to get AjaxProxy loading from the HTML5 cache.

    regards

    Tom

  4. #4
    Sencha Premium Member
    Join Date
    Jun 2011
    Location
    Nottingham, UK
    Posts
    24
    Vote Rating
    0
    mysterydiner is on a distinguished road

      0  

    Cool Solved

    Solved


    Doh! its so simple - just add the noCache:false parameter to your proxy config et walla!

Thread Participants: 1