Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Ext GWT Premium Member
    Join Date
    Dec 2011
    Location
    Earth
    Posts
    243
    Vote Rating
    1
    nbuesing is on a distinguished road

      0  

    Default SpinnerField doesn't work in Development (works find in production mode)

    SpinnerField doesn't work in Development (works find in production mode)


    When I am using the Development Mode Plugin for Eclipe and add a SpinnerField (and I believe the same is true for ComboBox), the SpinnerField doesn't work. The value sometimes changes with the up and down buttons, but usually it doesn't. If I enter a value and then submit my form, the value I entered is not accessible from the spinner.getValue(), it returns null.

    Now, when I compile my GWT and run my application in production mode, the spinner field works just fine.

    Now, I took the Ext GWT Explorer Demo and ran that from my IDE in development mode, and I don't see issues. So, it appears it is something that I'm doing that only shows up as an issue in developer mode (I don't think there is any coding changes since beta2 that would have fixed this).

    Any thoughts or ideas?

    Thanks.

  2. #2
    Ext GWT Premium Member
    Join Date
    Dec 2011
    Location
    Earth
    Posts
    243
    Vote Rating
    1
    nbuesing is on a distinguished road

      0  

    Default


    So, I don't think this is dev/prod issue, but actually how the spinner is used

    1. Buttons work if I use them before changing value of spinner via field.
    2. If I put my cursor in the field, I can still use the spinner buttons.
    3. If I change the value in the field, the spinner buttons don't work unless I leave focus of the text field (hitting spinner buttons does not leave focus, need to select different field on the form)
    4. If I change the value of the spinner via the text field (and then navigate to another field) then the push buttons work again, however it increments/decrements from the last value used by the spinners, not by what I entered into the text field.
    5. If I enter a value manually, getValue() doesn't return it, only the value entered via the spinners.

    I can reproduce this with the showcase "Duration(s)" field.

    http://www.sencha.com/examples-dev/#...e:formsexample

  3. #3
    Ext GWT Premium Member
    Join Date
    Dec 2011
    Location
    Earth
    Posts
    243
    Vote Rating
    1
    nbuesing is on a distinguished road

      0  

    Default


    So, it looks like I'm stumbling on a few different issues.

    I have an issue where in development mode a combo box and spinner do not work, where they were in production mode.

    Any, I have the issue of the spinner (in my first reply) that affects the spinner in box production and development mode.

    It seems like my "dev only" mode is dependent on my parentage of widgets (or something along those lines, still investigating). I am currently trying to figure out what is going on with that.

  4. #4
    Ext GWT Premium Member
    Join Date
    Dec 2011
    Location
    Earth
    Posts
    243
    Vote Rating
    1
    nbuesing is on a distinguished road

      0  

    Default


    The whole dev/prod issues seem to be related to the use of RootLayoutPanel that happened prior to RootPanel being called. For some reason that must be causing events to be blocked from the GXT components. The other issues remain (as indicated in my reply to my original post and verifying wtih the showcase examples.

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar