We're having a similar but sort of reversed problem. When we updated to 4.1, we started seeing SQL errors on saving or creating some of our models.

As it turns out, the dateFormat on the model's field is "c", which our database understood. I'm not sure if it was this fix or if the code changed somewhere else, but it appears as though something has made it so that "c" by default now includes the GMT offset, which our database does not understand.

Looking at the documentation, I see a wide range of acceptable ISO8601 formats supplied when given the "c" option, but I don't see how to specify the specific subset you want to use. In our case, we don't want the GMT offset. Is there a way to set this, perhaps as an application-wide setting for Ext.Date, or should we just create a standard dateFormat object that contains only what we want and is not dependent on the way Ext.Date is configured?