Success! Looks like we've fixed this one. According to our records the fix was applied for TOUCH-1644 in a recent build.
  1. #1
    Sencha User
    Join Date
    Jan 2012
    Posts
    20
    Vote Rating
    0
    ASraniel is on a distinguished road

      0  

    Default [PR4] Ajax proxy pageParam ignored

    [PR4] Ajax proxy pageParam ignored


    When using the ajax proxy, the pageParam, startParam and limitParam variables are ignored when set to undefined. The default value is used anyway in the request.

    The example code shows this. This bug is seperate from the fact that XML readers don't work at all in PR4 (i hope for a hotfix soon).

    Here is my code:
    Code:
    Ext.define('DMAlert.store.Dictionary', {    extend  : 'Ext.data.Store',
        config: {
            model   : 'DMAlert.model.Dictionary',
            proxy: {
                type: 'ajax',
                url : 'xml/dictionary.xml',
                noCache: false,
                
                pageParam: undefined,
                startParam: undefined,
                limitParam: undefined,
                reader: {
                    type: 'xml',
                    rootProperty: 'dictionary',
                    record: 'word',
                }
            }
        }
    });

  2. #2
    Sencha - Sencha Touch Dev Team Jamie Avins's Avatar
    Join Date
    Mar 2007
    Location
    Redwood City, California
    Posts
    3,661
    Vote Rating
    21
    Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough Jamie Avins is a jewel in the rough

      0  

    Default


    Thank you for the detail, we have XML in place for the next release and should be able to test this now.

    Sencha Inc

    Jamie Avins

    @jamieavins

  3. #3
    Sencha User
    Join Date
    Mar 2007
    Location
    Haarlem, Netherlands
    Posts
    1,243
    Vote Rating
    9
    TommyMaintz will become famous soon enough TommyMaintz will become famous soon enough

      0  

    Default


    This has been fixed for the next release. In order for it to work you would have to set the values to null instead of undefined. In the new config system, setting something to undefined will use the default value, setting it to null won't.

    Because we believed having to set these to null every time you didn't want to send them was rather ugly, we have also added a new configuration on proxy called enablePagingParams. By configuring this to be false or calling proxy.setEnablePagingParams(false) (default is true to stay backwards compatible), none of the paging parameters will be sent with your request.

  4. #4
    Sencha User
    Join Date
    Jan 2012
    Posts
    20
    Vote Rating
    0
    ASraniel is on a distinguished road

      0  

    Default


    This is great thank you very very much

Thread Participants: 2