Success! Looks like we've fixed this one. According to our records the fix was applied for a bug in our system in a recent build.
  1. #1
    Sencha User
    Join Date
    Feb 2008
    Posts
    36
    Vote Rating
    0
    yozefff is on a distinguished road

      0  

    Default Issues with stores , 1.2.2 build 48 , mac osx lion

    Issues with stores , 1.2.2 build 48 , mac osx lion


    Hi I have some issues. I "fixed" some of them, but I think they are still issues.

    First, some specs

    Hardware : Macbookpro , Max OSX Lion
    Software : Ext Designer 1.2.2 build 48 . ExtJS 3.1


    1) Errors export Designer 1.2.2 build 48 osx

    I've already sumitted this issue :
    http://www.sencha.com/forum/showthre...2-build-48-osx

    Lukly I already "fixed" this.

    The problem ocures when you have a component with a store (for example dataview) , promoted to class. You have probably set the store in the class and the initiated object set empty.

    With 1.1.2 the instance extended the promoted class, so the store was set. But with 1.2.2 the instance doesn't "extend" the class, so the instance has a property "store" set empty , resulting a error a component is missing a store.

    The "fix" is setting the store in the instance. So now I managed to export the project.


    2) Store undefined after export

    So I "fixed" issue 1. But now, when I start my application. I get errors like "store undefined". When I console.log the component and retrieve the store property, the property was emtpy.

    But I also "fixed" that by rebinding the store to the component with the .bindStore() function.


    3) Combobox not working

    So now I have a combobox. I also get the same store issue so I "fixed" it by rebinding the store to the combobox. That worked. BUT .. When I set the value , the combobox doesn't show the displayField , but just the value I just set.

    Fox example I have

    display = "my test"
    value = "yes"

    I set the combobox value to "yes" , it should display "my test" in the combobox , but it shows "yes". When I trigger the combobox by clicking the comboxbox, it makes the request to the server , get the json response and updates the combobox and then it shows the displayField.

    I tried to load the store before the component is rendered, but no luck


    4) No Ext.reg

    I wondered why this all fails with the stores. Lucky for my I have a 1.1.2 version wich still works , so I compared the javascript. I noticed that with 1.2.2 , the javascript export for the store was different.

    To illustrate:

    Code:
    /* 1.2.2 build 48 Mac osx lion */
    test = Ext.extend(Ext.data.JsonStore, {
        constructor: function(cfg) {
            cfg = cfg || {};
            test.superclass.constructor.call(this, Ext.apply({
                storeId: 'test'
            }, cfg));
        }
    });
    Code:
    /* 1.1.2*/ 
    test = Ext.extend(Ext.data.JsonStore, {
        constructor: function(cfg) {
            cfg = cfg || {};
            test.superclass.constructor.call(this, Ext.apply({
                storeId: 'test'
            }, cfg));
        }
    });
    Ext.reg('test', test);new test();
    As you can see, 1.2.2 doesn't use Ext.reg anymore .. maybe that's the cause why I have issue 2 (undefined store).


    5) Designer 2 beta can't load my xds

    Just like the title says .. I downloaded the Sencha Designer 2 beta and tried to open my 1.2.2 xds. But I get

    TypeError : 'undefined'is not an object


    I hope that I've helped others with this and the fantastic team of Sencha Designer

  2. #2
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,413
    Vote Rating
    129
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    1) Ok.
    2) If you can provide a sample application we could look into this further
    3) You are correct in assuming that the store needs to be loaded before the value is set. This will fix this problem.
    4) Is the userXType set?
    5) We have a bug filed for this DSGNR-1284. This occurs when double clicking on a project that is an unsupported framework type. If you start Designer 2.0 and click on a framework (Ext 4.x or Touch 2.x) and then try to open the project you will see a message along the lines of "This project is targeting an unsupported framework (ext3.x)"
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  3. #3
    Ext JS Premium Member
    Join Date
    Sep 2010
    Posts
    50
    Vote Rating
    0
    extjs@araneum.nl is on a distinguished road

      0  

    Default


    Ok .. did some tests (yozeff is also my account).

    1) First I created a project in 1.1.2 (see attachment 1.1.2.zip)

    This works

    2) Then I opened the xds in designer 1.2.2 build 48 (attachment 1.1.2_cannot_export.zip). It converted my xds , but I cannot export

    3) The new converted xds, I set the store in the instance and export the project (attachment 1.2.2-converted-from-1.1.2.zip)

    4) Now I can export, but I cannot intiate the combobox (attachment 1.2.2-converted-from-1.1.2-stores-fix.zip). So I added a js to initiate the store BEFORE the application is started (see index.html)

    Code:
    Ext.reg('myStore', myStore);new myStore();
    Now it works

    5) Now try import the xds from step 4 into Sencha Designer 2.

    Hopes this helps
    Attached Files

  4. #4
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,413
    Vote Rating
    129
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Are you able to use Ext 4.x?

    Can you try to see if you have the same problems in Designer 2 starting with Ext 4.x?
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  5. #5
    Ext JS Premium Member
    Join Date
    Sep 2010
    Posts
    50
    Vote Rating
    0
    extjs@araneum.nl is on a distinguished road

      0  

    Default


    At this moment we (my company) cannot use Ext 4.x. Our framework/applications is build on Ext 3.x.

    Ext 4.x is still on our roadmap but needs reseach and development.

    But now, we cannot use 1.2.2 (to prepare us better for the transition to Ext 4), because of the store problem. So now we are sticking with 1.1.2

    I hope Sencha will make a new build for 1.2.2 to fix the store problem

  6. #6
    Ext JS Premium Member
    Join Date
    Sep 2010
    Posts
    50
    Vote Rating
    0
    extjs@araneum.nl is on a distinguished road

      0  

    Default


    Any word about this issue? Because now, we cannot use 1.2.2. We really want to udate from 1.1.2 to 1.2.2 , but this stores issue is a major issue.

  7. #7
    Sencha User
    Join Date
    Jul 2009
    Posts
    24
    Vote Rating
    0
    Palastanga is on a distinguished road

      0  

    Default


    I'm also affected by this bug, I need to manually add all of the Ext.reg() lines now for everystore I have defined. This has happened since moving to 1.2.2 on OSX and upgrading the project, so I can't go back now.

    Eventually I want to be using ExtJS 4.x but i'm deliverying a 6+ month project and need to get my first release out on 3.3.x first, otherwise I'll never deliver.

  8. #8
    Ext JS Premium Member
    Join Date
    Sep 2010
    Posts
    50
    Vote Rating
    0
    extjs@araneum.nl is on a distinguished road

      0  

    Default


    any thoughts on this?

  9. #9
    Sencha User
    Join Date
    Feb 2008
    Posts
    36
    Vote Rating
    0
    yozefff is on a distinguished road

      0  

    Default


    STILL no word about this issue? I know the new Designer is very nice, but please fix this issue for us (Designer 1.x users).

    Every time I create a new store , I have to manually add the js code to initiate the store. We (Designer 1.x users) pay good money for your software and now with this build you (Sencha) broke it.

  10. #10
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,413
    Vote Rating
    129
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    We will fix it in the next maintenance release of Ext Designer 1.2.x.
    Aaron Conran
    @aconran
    Sencha Architect Development Team