Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha Premium Member
    Join Date
    Mar 2008
    Posts
    92
    Vote Rating
    1
    kveeiv is on a distinguished road

      0  

    Default Incorrect handling of configs: autoCapitalize, autoComplete, autoCorrect, (etc.?)

    Incorrect handling of configs: autoCapitalize, autoComplete, autoCorrect, (etc.?)


    These tri-state (true/false/null) boolean-type configurations are displaying as checkboxes in the component configs.

    Checking them means true, but unchecking them seems to mean use component default, not false. In these cases, the defaults of these is null.

    There seems to be no way to make these configuration options get saved with a false value, and this might extend out to other true/false/null configuration options. Without the ability to set these config options to false, some of my textfields are resulting in some pretty poor usability.

    I would perhaps suggest a typical tri-state checkbox for these configuration types, with the grayed state representing the default/inherited value.

  2. #2
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,249
    Vote Rating
    121
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Handling the tri-state nature of boolean configurations is already scheduled to be addressed in our next sprint. Thanks for the suggestions.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  3. #3
    Ext JS Premium Member
    Join Date
    Oct 2010
    Posts
    103
    Vote Rating
    6
    abierbaum is on a distinguished road

      0  

    Default


    Any progress on this. I just got bit by the same problem.

Thread Participants: 2