Success! Looks like we've fixed this one. According to our records the fix was applied for DSGNR-1429 in a recent build.
  1. #1
    Sencha User
    Join Date
    Aug 2011
    Location
    Cedar Rapids, IA
    Posts
    63
    Vote Rating
    1
    aoathout is on a distinguished road

      0  

    Default Designer 2 build: 288 and ST Beta 3 Viewport autoMaximize

    Designer 2 build: 288 and ST Beta 3 Viewport autoMaximize


    What would be the best way to set the viewport to autoMaximize: true with designer? I've tried adding 'Ext.Viewport.setAutoMaximize(true);' to the Application launch method but I get the following error:

    Uncaught TypeError: Object doAutoMaximizeOnReady has no method 'call' sencha-touch-all-debug.js 75495

    I know I can go into the designer.js file and add 'viewport: { autoMaximize: true}' but that will get crushed on next deploy.
    -->

  2. #2
    Sencha User
    Join Date
    Aug 2011
    Location
    Cedar Rapids, IA
    Posts
    63
    Vote Rating
    1
    aoathout is on a distinguished road

      0  

    Default


    Am I the only one having this issue? Or is it a known issue? It could be user error, just looking for advice.

    Thanks.
    -->

  3. #3
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,358
    Vote Rating
    127
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    I've moved this to the bug forums and we will take a look at it. You should be able to easily configure the viewports values via the Application node.
    Aaron Conran
    @aconran
    Sencha Architect Development Team
    -->

  4. #4
    Sencha User
    Join Date
    Feb 2012
    Posts
    1
    Vote Rating
    0
    evolutionlab is on a distinguished road

      0  

    Exclamation


    i have the same exact proble with the 2.0 final.

    If i try this code in the application launch:
    Ext.Viewport.setAutoMaximize(true);

    I get the following error:
    Uncaught TypeError: Object doAutoMaximizeOnReady has no method 'call'

    I need that to switch this options true or false based on the user OS (true for iOS, false for Android).
    -->

  5. #5
    Sencha User
    Join Date
    Aug 2011
    Location
    Miami, Florida
    Posts
    24
    Vote Rating
    -1
    tmort is an unknown quantity at this point

      0  

    Default


    Having the same issue. Is there a way to toggle this via the designer itself?
    -->

  6. #6
    Sencha - Architect Dev Team jjohnston's Avatar
    Join Date
    Sep 2010
    Posts
    567
    Vote Rating
    20
    jjohnston will become famous soon enough jjohnston will become famous soon enough

      0  

    Default


    Thanks for the report. Our latest dev code introduces the ability to add a Viewport configuration as a child of the Application node in the project inspector, so you can customize the viewport's configuration properties such as autoMaximize.
    Jason Johnston
    @lojjic
    Sencha Architect Development Team
    -->

  7. #7
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,358
    Vote Rating
    127
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Fixed in build 337, pushed out today.
    Aaron Conran
    @aconran
    Sencha Architect Development Team
    -->