Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Sencha User
    Join Date
    Feb 2012
    Posts
    5
    Vote Rating
    0
    kyleSencha is on a distinguished road

      0  

    Default TextField is not found in IE9.

    TextField is not found in IE9.


    I used TextField in FormPanel as items in a page, then I put the page in a tabpanel as a tab page.

    I open this tab page(called page1), then I open another tab page. I click the tab of page1 to active it, then the TextField in page1 cann't be found.

    I used this tag '<meta http-equiv="X-UA-Compatible" content="IE=8" />' in my main page, and the problem was found in IE9.

  2. #2
    Sencha User WesleyMoy's Avatar
    Join Date
    Oct 2009
    Location
    Redwood City, California
    Posts
    402
    Vote Rating
    2
    WesleyMoy is on a distinguished road

      0  

    Default


    Have you tried running your app without the X-UA-Compatible header?

    Because GWT compiles a different permutation for each browser, it shouldn't be necessary or desirable to run IE9 in IE8 mode. Is there any particular reason why you would need this?

  3. #3
    Sencha User
    Join Date
    Feb 2012
    Posts
    5
    Vote Rating
    0
    kyleSencha is on a distinguished road

      0  

    Default


    Yes, I have try it. When I remove the X-UA-Compatible header, IE8 and IE9 will run the page in IE7 mode. But our portal do not perfect support for IE7.

  4. #4
    Sencha User WesleyMoy's Avatar
    Join Date
    Oct 2009
    Location
    Redwood City, California
    Posts
    402
    Vote Rating
    2
    WesleyMoy is on a distinguished road

      0  

    Default


    Usually, a document with a valid DOCTYPE declaration and no X-UA-Compatible header will be rendered using the most up-to-date renderer available. Because both GWT and Ext GWT layouts depend on your document being in standards mode, you should already have a valid DOCTYPE for your host page. See http://blogs.msdn.com/b/ie/archive/2...ment-mode.aspx and http://ieblog.members.winisp.net/mis...ent%20Mode.svg for a more detailed description of how a document mode is chosen in IE8 and IE9.

    If this is not an option, consider using <meta http-equiv="X-UA-Compatible" content="IE=9" />. This will force both IE8 and IE9 to render their pages with their highest-versioned engines, which are IE8 and IE9 respectively.

  5. #5
    Sencha User
    Join Date
    Feb 2012
    Posts
    5
    Vote Rating
    0
    kyleSencha is on a distinguished road

      0  

    Default


    Thanks for your help. The problem is solved by using <meta http-equiv="X-UA-Compatible" content="IE=9" />.

Thread Participants: 1

Tags for this Thread