Hi guys,

If I define an Ext Direct Proxy with an api configuration without defining the API location in the project setup, the api configuration for the proxy winds up as a string. This also happens if the API cannot be found when you launch the designer. This happens to me all the time because my tomcat isn't always running when I launch the Designer.

To recreate.

Add a direct proxy without setting an Ext Direct URL in the project settings.
Attempt to put in a valid api object.
Result is a string instead of an object.

Add a Ext Direct URL to the project settings.
Return to the proxy and re enter the correct api object.
Result is an object as is appropriate.

Exit designer and turn off your Ext Direct API service.
Re open the designer.
It will pop up with an error in the project settings for the Ext Direct URL.
If you cancel out of the settings box, and return to your proxy you will see that the api has again be converted to a string instead of an object.

To resolve the above in case anyone else gets to here, do the following:
Restart your API service (or reconnect to it if you've lost connection somehow)
Open the project settings (you'll notice that the API url isn't showing an error outline anymore)
Save the project settings.
copy the api config value.
Delete the api config value.
past the api config value back in.
It should now be an object again.

Thanks
Bob