Wait! Looks like we don't have enough information to add this to bug database. Please follow this template bug format.
  1. #1
    Touch Premium Member
    Join Date
    Mar 2011
    Posts
    13
    Vote Rating
    0
    steveaxelrad is on a distinguished road

      0  

    Default Empty Toolbox in Build 337

    Empty Toolbox in Build 337


    Toolbox is completely empty whether placed or left or right side. Components are still available thru the overhead menu under "Edit: New Component" but nothing is available in the Toolbox. This error did not occur in the previous build. This iMac was running Snow Panther, so I upgraded to OSX (10.7.3 - Lion), which did not correct the problem.

    A MacBook Pro running a version of Snow Leopard is not having this problem.

    It may be specific to this one machine, but I have not found the source of the error.

  2. #2
    Touch Premium Member
    Join Date
    Mar 2011
    Posts
    13
    Vote Rating
    0
    steveaxelrad is on a distinguished road

      0  

    Default Missing Folder: ~/Library/Application Support/Sencha, Inc./Sencha Designer 2.0/

    Missing Folder: ~/Library/Application Support/Sencha, Inc./Sencha Designer 2.0/


    This folder was deleted from the library: ~/Library/Application Support/Sencha, Inc./Sencha Designer 2.0/

    I am unable so far to get a new install to re-build this library folder.

  3. #3
    Sencha Premium Member
    Join Date
    Mar 2008
    Posts
    92
    Vote Rating
    1
    kveeiv is on a distinguished road

      0  

    Default


    My toolbox is also empty now. I can use the same Edit menu workaround for the moment, but this is very crippling.

    I am on the latest version of Lion.
    I still have the Application Support folder.

    I removed the xds-2.0.0.000337.ion file per the downgrade instructions in:
    http://www.sencha.com/forum/showthre...l=1#post750916

    This restored the contents of my toolbox, but my project would no longer save. There were no errors or feedback given in the UI, but the system console showed some 'undefined' is not an object on line 0 source Id: undefined messages, I presume because I had already upgraded this project to 337.

    I allowed designer to upgrade again. The xds-2.0.0.000337.ion file is present as expected, but my toolbox is once again empty. My project will save again however (and of course, I'm using source control so I'm not afraid of losing anything).

    The same incorrect toolbox behavior is exhibited when creating a new empty project from scratch.

  4. #4
    Sencha Premium Member
    Join Date
    Mar 2008
    Posts
    92
    Vote Rating
    1
    kveeiv is on a distinguished road

      0  

    Default


    Quote Originally Posted by kveeiv View Post
    I can use the same Edit menu workaround for the moment, but this is very crippling.
    This also doesn't work for adding basic functions to my controllers, so for now I am creating override classes and storing those functions there.

  5. #5
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,247
    Vote Rating
    121
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Wow, if you remove the application support folder completely and reinstall does it work?

    We are unable to reproduce this problem.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  6. #6
    Sencha Premium Member
    Join Date
    Mar 2008
    Posts
    92
    Vote Rating
    1
    kveeiv is on a distinguished road

      0  

    Default


    Quote Originally Posted by aconran View Post
    Wow, if you remove the application support folder completely and reinstall does it work?

    We are unable to reproduce this problem.
    This worked for me. I didn't uninstall the app, I just moved the entire Application Support/Sencha, Inc./Sencha Designer 2.0 folder out of the way and let the app update to rebuild it. This added the 268 and 337 ion files, and gave me a fresh sqlite settings database. Maybe it was something in those settings that caused this? I will mail you an archive with the old and new versions, just in case its of any value for you. In any event, I'm good to go again, thanks for the suggestion.

  7. #7
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,247
    Vote Rating
    121
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    I have a feeling it has to do with the sqlite db. Please send it over and hopefully we can determine what the issue is.

    Thanks,
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  8. #8
    Touch Premium Member
    Join Date
    Mar 2011
    Posts
    13
    Vote Rating
    0
    steveaxelrad is on a distinguished road

      0  

    Default


    Quote Originally Posted by aconran View Post
    Wow, if you remove the application support folder completely and reinstall does it work?

    We are unable to reproduce this problem.
    In my case, the Application support folder for Sencha was already deleted and cannot be rebuilt.

  9. #9
    Sencha User
    Join Date
    Mar 2012
    Posts
    4
    Vote Rating
    0
    CasualGamer is on a distinguished road

      0  

    Default Same thing in Win7

    Same thing in Win7


    Same thing happened to me. After upgrading, whenever I try to open up my project, I get a window saying "An undexpected error occurred prior to upgrading. Please report this on the forums. Note your project is fine" This message appears for every xds file I try to open. It does not appear when I open the designer first and browse to a project.

    After hitting close on that error, I find that the toolbox on the left is completely empty. I've uninstalled, rebooted and rerun the installer I used the first time. Help > About still tells me it's build 337, though everything is installed to a folder named "SenchaDesigner-2.0.0.000268".

    Is there anything I can try to get the toolbar back?

    Thanks in advance.

  10. #10
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,898
    Vote Rating
    62
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    Ok so know that there is a bug concerning windows only that affects users upgrading their projects. It could be that opening the project from the splash is a work around but this didn't work for me. I have a fix for the issue but I'm not sure when it will be pushed out.

    I'm happy to convert any projects you guys would like so it's compatible with build 341 be them 1.2 extjs4 or any 2.x projects. Simply send me a PM and we'll work out email arrangements.
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team