1. #1
    Sencha User
    Join Date
    Oct 2011
    Posts
    34
    Vote Rating
    0
    dakamojo is on a distinguished road

      0  

    Default Error when trying to Simulate app

    Error when trying to Simulate app


    I have gotten past my packaging issues. Now when I choose Deploy and then Simulate, I get the following message in a terminal window.

    Code:
    Last login: Thu Mar 29 09:34:52 on ttys000
    ddavismbp:~ darrelldavis$ /var/folders/d5/277mgmg09mq99jjw5gvf5v5w000123/T/temp.sh ; exit;
    running sencha package run /Users/darrelldavis/Projects/SenchaProjects/Honeylogue/simulator.json
    The application was successfully packaged
    Path: //Users/darrelldavis/build/Honeylogue.app
    Device: iphone
    [DEBUG] 2012-03-29 09:36:20.157 stbuild_template[50359:17903] The requested URL was not found on this server.
    The app is getting installed on the simulator and it is launching. I think this is indicating that the native shell app is not finding the designer.html file in the packaged app.

    I look in the build path and I find Honeylogue.app. I examine the contents of that file and I see a webapp folder which contains designer.html. All of the Sencha code appears to be in the app folder.

    When the native app gets launched, it is supposed to load designer.html from within the app, correct? Its not looking for it on my Mac, correct?

  2. #2
    Sencha User joostvanhassel's Avatar
    Join Date
    Jan 2012
    Location
    Rotterdam, The Netherlands
    Posts
    102
    Vote Rating
    1
    joostvanhassel is on a distinguished road

      0  

    Default


    not sure this is gonna work, but try renaming designer.html to index.html to see if that helps

  3. #3
    Sencha User
    Join Date
    Oct 2011
    Posts
    34
    Vote Rating
    0
    dakamojo is on a distinguished road

      0  

    Default


    Quote Originally Posted by joostvanhassel View Post
    not sure this is gonna work, but try renaming designer.html to index.html to see if that helps
    That solved it (sort of). Outside of designer I copied designer.html to index.html and then manually ran "sencha pacakge run" and the simulator launched and my app appeared.

    It appears that Designer creates designer.html but the packager assume the file is index.html. I don't see a setting in either where I can change this behavior. Am I missing something?

  4. #4
    Sencha User joostvanhassel's Avatar
    Join Date
    Jan 2012
    Location
    Rotterdam, The Netherlands
    Posts
    102
    Vote Rating
    1
    joostvanhassel is on a distinguished road

      0  

    Default


    I haven't seen a setting for this either, but i kind of like it, as it allows me to re-use my (changed) index.html

  5. #5
    Sencha User
    Join Date
    Jun 2009
    Location
    Redwood City, CA
    Posts
    197
    Vote Rating
    6
    CaliLuke is on a distinguished road

      0  

    Default


    the UI to tweak your simulator settings will be coming. Thanks for your patience!
    --
    Luca Candela
    twitter: @luckymethod

Thread Participants: 2