1. #1
    Sencha Premium Member
    Join Date
    Oct 2009
    Location
    Leeds
    Posts
    47
    Vote Rating
    3
    damo is on a distinguished road

      0  

    Default SDK Tools download

    SDK Tools download


    Downloaded the latest SDK tools from the ExtJS 4 product page which is version 2.0.0.

    I cannot seem to get this to work no matter what I do.

    I am trying to use this commad as I'm working with an ExtJS 3 project.

    Code:
    sencha build -p file.jsb3 -d js/ -v
    I just get a blank line shown in the cmd prompt.

    Can you please update the SDK product page with previous working version of the SDK tools as I have recently had to change work laptops and now I have no way to build my JSB files and compress etc for production.

    Thank you,
    Damo

  2. #2
    Sencha User aw1zard2's Avatar
    Join Date
    Sep 2009
    Location
    Dallas, Texas
    Posts
    561
    Vote Rating
    28
    aw1zard2 has a spectacular aura about aw1zard2 has a spectacular aura about

      0  

    Default


    The newest is Sencha SDK Tools Beta2 which is working fine for me.
    Look in the Sencha Touch 2.0 forums for the download and instructions on it.

  3. #3
    Sencha Premium Member
    Join Date
    Oct 2009
    Location
    Leeds
    Posts
    47
    Vote Rating
    3
    damo is on a distinguished road

      0  

    Default


    Nope downloaded that and it's still not working.

    Just get a blank line in the cmd prompt and nothing created in the js folder.

  4. #4
    Sencha User aw1zard2's Avatar
    Join Date
    Sep 2009
    Location
    Dallas, Texas
    Posts
    561
    Vote Rating
    28
    aw1zard2 has a spectacular aura about aw1zard2 has a spectacular aura about

      0  

    Default


    Your not doing the command correct.
    You have to tell it the html page.
    If your using the Ext JS 4.x.x, if your trying to do something with Sencha Touch 2 its a different process.

    There are multiple topics on the same issues check them out in this forum thread.

  5. #5
    Sencha Premium Member
    Join Date
    Oct 2009
    Location
    Leeds
    Posts
    47
    Vote Rating
    3
    damo is on a distinguished road

      0  

    Default


    I'm working with a ExtJS3 project.

    Previously the "sencha build" command took a jsb3 file and created a single js file from that jsb3 file.

    It was irrellevant what was even in your js files as literally all it was doing was concatenating a bunch of js files into one and removing comments, thats it.

    I'm happy for Sencha to drop support for working with ExtJS 3 projects with the SDK tools but at least keep up a link to a sench tools SDK which did work.

  6. #6
    Sencha Premium Member
    Join Date
    Oct 2009
    Location
    Leeds
    Posts
    47
    Vote Rating
    3
    damo is on a distinguished road

      0  

    Default



    Also I just tried to download JSBuilder3 as that's all I want out of this but returns different errors which seems to be dependancy related but there's no docs for it for me to look at any further...

  7. #7
    Sencha User aw1zard2's Avatar
    Join Date
    Sep 2009
    Location
    Dallas, Texas
    Posts
    561
    Vote Rating
    28
    aw1zard2 has a spectacular aura about aw1zard2 has a spectacular aura about

      0  

    Default


    You need JSBuilder 2 for Ext JS 3.
    Link is below.
    http://www.sencha.com/products/jsbuilder/download/jsbuilder-2.0.0


    Got the link from the Ext JS 3.4 product page.
    http://www.sencha.com/products/extjs3/

  8. #8
    Sencha Premium Member
    Join Date
    Oct 2009
    Location
    Leeds
    Posts
    47
    Vote Rating
    3
    damo is on a distinguished road

      0  

    Default


    I've tried JSBuilder 2 which is what I meant in the post above it, that doesn't work either.

    I just get a error which states "Exception in thread "main" ....: bad number in .class file"

    From memory the JSBuilder2 jar never worked for me which is why I used the "sencha build" command from the sencha tools sdk.

  9. #9
    Sencha User aw1zard2's Avatar
    Join Date
    Sep 2009
    Location
    Dallas, Texas
    Posts
    561
    Vote Rating
    28
    aw1zard2 has a spectacular aura about aw1zard2 has a spectacular aura about

      0  

    Default


    Sencha SDK Tools 2+ works with the new MVC and dynamic loader which didn't exist in Ext JS 3.
    If you need Sencha SDK Tools 1.2.2 I'll try and find the link otherwise I have the installer for it on my machine I can email it to you.

  10. #10
    Sencha User aw1zard2's Avatar
    Join Date
    Sep 2009
    Location
    Dallas, Texas
    Posts
    561
    Vote Rating
    28
    aw1zard2 has a spectacular aura about aw1zard2 has a spectacular aura about

      0  

    Default


    Here is the link to the windows 1.2.2 beta.

    http://www.sencha.com/products/sdk-t...2-beta/windows

Thread Participants: 2

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar