1. #1
    Sencha User
    Join Date
    May 2011
    Posts
    27
    Vote Rating
    5
    Reggae is on a distinguished road

      0  

    Default Direct Store not working in Ext 4.1 RC 2

    Direct Store not working in Ext 4.1 RC 2


    Why did you change the following lines of code (ExtJs 4.0.2) in the Ext.proxy.Direct class from:

    Code:
    if(method.ordered){
    if(method.len >0){if(paramOrder){for(len = paramOrder.length; i < len;++i){                            args.push(params[paramOrder[i]]);}}elseif(me.paramsAsHash){                        args.push(params);}}}else{                args.push(params);}
    
    to (Ext 4.1. RC2):
    Code:
                method = fn.directCfg.method;
                args = method.getArgs(params, me.paramOrder, me.paramsAsHash);
    The code of ExtJs 4.1 RC2 causes an error when trying to load a store. If I replace the code with the one from ExtJs 4.0.2 everything works fine.

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    9,197
    Vote Rating
    482
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      0  

    Default


    Have you tried RC3? It may be related to this report:
    http://www.sencha.com/forum/showthread.php?177636

    Regards,
    Scott.

Thread Participants: 1