1. #31
    Sencha User
    Join Date
    Jan 2012
    Posts
    4
    Vote Rating
    0
    gersoncfilho is on a distinguished road

      0  

    Default Same problem for me.

    Same problem for me.


    Just installed the SDK and following the instruction after the sencha command it return this error.

  2. #32
    Sencha User
    Join Date
    Jan 2012
    Posts
    4
    Vote Rating
    0
    gersoncfilho is on a distinguished road

      0  

    Default Problem Solved

    Problem Solved


    Hi, we have to include the sencha sdk in the /etc/paths.

    Code:
    sudo vi /etc/paths
    After insert the sencha sdk path to the file save and close the file.

    Then, in the terminal, navigate to your project folder, and from there, call the command.

    Worked fine for me.

    Best regards.

  3. #33
    Sencha User
    Join Date
    Sep 2012
    Posts
    1
    Vote Rating
    0
    jamesclavel is on a distinguished road

      0  

    Default simple fix for the problem...

    simple fix for the problem...


    System: OS X Lion 10.7.2

    Installed Sencha SDK Tools in (/Application/SenchaSDKTools-2.0.0-beta3)
    Download and Unzip Sencha Touch 2.0.1.1 to your webserver's localhost folder.

    then you can use the "sencha" command in terminal. (close all terminal windows and re-open to apply changes in .bash_profile path additions)

    by typing "sencha" in command line should show similar output as below:
    Screen Shot 2012-09-12 at 1.32.47 AM.png
    if similar output, then sencha SDK Tools working properly.

    for easy access, extract the Sencha Touch 2 (sencha-touch-2.0.1.1-gpl.zip - as of writing) to your webserver's localhost. Sencha SDK Tools verify a valid sencha SDK if it finds the .senchasdk file. see image below:

    Screen Shot 2012-09-12 at 1.40.38 AM.png
    i keep my sencha touch SDK inside (/Users/my_name/Sites/sencha) then my projects inside that folder. so i create sencha touch projects using command line:

    sencha generate app app_name ./app_folder


    then that's it. so accessing it to my browser is easy as 123.
    (I'm using virtual-host configuration on my XAMPP local server)

    http://sencha/GS/
    Attached Images

  4. #34
    Sencha User
    Join Date
    Jul 2012
    Posts
    13
    Vote Rating
    1
    axeff is on a distinguished road

      0  

    Default


    Getting that identical error after moving to SDK 2.1.0-commercial on Mac.
    Steps for reproducing:
    1. Download and unzip sencha-touch-2.1.0-commercial.zip
    2. Change to directory and list contents
    Code:
    drwxr-xr-x@   3 axelf  staff   102B  7 Nov 11:25 builds
    drwxr-xr-x@   3 axelf  staff   102B  7 Nov 11:25 cmd
    drwxr-xr-x@  12 axelf  staff   408B  7 Nov 11:25 docs
    drwxr-xr-x@  41 axelf  staff   1,4K  7 Nov 11:25 examples
    -rw-r--r--@   1 axelf  staff   262B  5 Nov 22:32 getting-started.html
    -rw-r--r--@   1 axelf  staff   523B  5 Nov 22:32 index.html
    -rw-r--r--@   1 axelf  staff   2,0K  5 Nov 22:33 license.txt
    drwxr-xr-x@   5 axelf  staff   170B  7 Nov 11:25 microloader
    -rw-r--r--@   1 axelf  staff   208K  5 Nov 22:32 release-notes.html
    drwxr-xr-x@   7 axelf  staff   238B  7 Nov 11:25 resources
    -rw-r--r--@   1 axelf  staff   2,7M  5 Nov 22:34 sencha-touch-all-debug.js
    -rw-r--r--@   1 axelf  staff   657K  5 Nov 22:34 sencha-touch-all.js
    -rw-r--r--@   1 axelf  staff   494K  5 Nov 22:34 sencha-touch-debug.js
    -rw-r--r--@   1 axelf  staff    93K  5 Nov 22:34 sencha-touch.js
    drwxr-xr-x@  70 axelf  staff   2,3K  7 Nov 11:25 src
    -rw-r--r--@   1 axelf  staff     5B  5 Nov 22:32 version.txt
    Works when using sencha-touch-2.0.1.1-commercial
    1. Unzip the old sencha-touch-2.0.1.1-commercial.zip
    2. Change to directory and list contents
    Code:
    -rw-r--r--@   1 axelf  staff     1B  4 Jun 16:35 .senchasdk
    drwxr-xr-x@   3 axelf  staff   102B  4 Jun 16:35 builds
    drwxr-xr-x@   7 axelf  staff   238B  4 Jun 16:35 command
    drwxr-xr-x@  12 axelf  staff   408B  4 Jun 16:36 docs
    drwxr-xr-x@  36 axelf  staff   1,2K  4 Jun 16:35 examples
    -rw-r--r--@   1 axelf  staff   262B  4 Jun 16:35 getting-started.html
    -rw-r--r--@   1 axelf  staff   523B  4 Jun 16:35 index.html
    -rw-r--r--@   1 axelf  staff   1,0K  4 Jun 16:36 license.txt
    drwxr-xr-x@   5 axelf  staff   170B  4 Jun 16:35 microloader
    drwxr-xr-x@   7 axelf  staff   238B  4 Jun 16:35 pkgs
    -rw-r--r--@   1 axelf  staff   151K  5 Jun 09:54 release-notes.html
    drwxr-xr-x@   7 axelf  staff   238B  4 Jun 16:35 resources
    -rw-r--r--@   1 axelf  staff   2,3M  4 Jun 16:36 sencha-touch-all-debug.js
    -rw-r--r--@   1 axelf  staff   568K  4 Jun 16:36 sencha-touch-all.js
    -rw-r--r--@   1 axelf  staff   488K  4 Jun 16:36 sencha-touch-debug.js
    -rw-r--r--@   1 axelf  staff    91K  4 Jun 16:36 sencha-touch.js
    drwxr-xr-x@  67 axelf  staff   2,2K  4 Jun 16:35 src
    -rw-r--r--@   1 axelf  staff    56K  4 Jun 16:35 touch.jsb3
    -rw-r--r--@   1 axelf  staff     8B  4 Jun 16:35 version.txt
    File .senchasdk is there but copying to the new directory won't solve the problem... What can I do?

  5. #35
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    37,399
    Vote Rating
    849
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    SDK Tools should not be used with 2.1.0, Sencha Cmd should. The blog has links to Cmd.
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  6. #36
    Sencha User
    Join Date
    Oct 2012
    Posts
    1
    Vote Rating
    0
    schmitzmichael is on a distinguished road

      0  

    Default starte guide needs an update

    starte guide needs an update


    I ran in exactly the same issue.
    Sencha Touch SDK Tools are not compatible to the Sencha Touch SDK in Version 2.1
    Sencha CMD is working fine.
    http://www.sencha.com/learn/getting-...encha-touch-2/
    The starter Guide needs to be updated.

  7. #37
    Sencha User
    Join Date
    Nov 2012
    Posts
    8
    Vote Rating
    1
    Nikke is on a distinguished road

      1  

    Default


    Guides are out of date. Doesn't work at all on windows.

    Downloaded, extracted and tried 'sencha' giving me the lovely SDK not found error.

    Please update the guides.

    And also, please make a distinction between SDK and SDK Tools, because you're not always clear with what you mean. Explain that Sencha Touch IS actually the SDK. If I read the docs from my local webserver, it tells me to go download Sencha Touch SDK which translates for me in something additional I have to download, while I already got the SDK since I'm reading the docs from it. It's just a headache right now for everyone to figure out.

  8. #38
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Posts
    1,385
    Vote Rating
    138
    dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold

      0  

    Default


    Correct on the Touch 2.0 guide - we need a 2.1 version for sure.

    The new guides are here:

    http://docs.sencha.com/touch/2-1/#!/guide/command

    There is an issue with http://docs.sencha.com/touch/2-1/#!/guide/command_app in that it references "sencha app create" but that alias for "sencha generate app" was dropped in v3. The first linked guide has the generate app call correct.

    This doc fix has been merged but not staged/deployed yet so it should be fixed soon.
    Don Griffin
    Ext JS Development Team Lead

    Check the docs. Learn how to (properly) report a framework issue and a Sencha Cmd issue

    "Use the source, Luke!"

  9. #39
    Sencha User
    Join Date
    Nov 2012
    Posts
    1
    Vote Rating
    0
    lzc_qd is on a distinguished road

      0  

    Default


    Quote Originally Posted by schmitzmichael View Post
    I ran in exactly the same issue.
    Sencha Touch SDK Tools are not compatible to the Sencha Touch SDK in Version 2.1
    Sencha CMD is working fine.
    http://www.sencha.com/learn/getting-...encha-touch-2/
    The starter Guide needs to be updated.
    Completely agreed. I've just downloaded Sencha 2.1 commercial, and it only works with Sencha CMD.

    But the starter guide at http://www.sencha.com/learn/getting-...encha-touch-2/ misleads me to download Sencha SDK Tools. Here's the part that needs update:
    Things you'll need

    First, you'll need to download the free Sencha Touch 2 SDK and SDK Tools from the Sencha website.


    Appreciate if someone could update this asap to avoid frustrations for new users. Thanks

  10. #40
    Sencha User
    Join Date
    Dec 2012
    Posts
    1
    Vote Rating
    0
    alanfinke is on a distinguished road

      0  

    Default What worked for me on Mac (sencha-touch-2.1.0-commercial)

    What worked for me on Mac (sencha-touch-2.1.0-commercial)


    Installing sencha-touch-2.1.0-commercial
    On Mac OS X, version 10.7.5

    1) Install Git:
    http://git-scm.com/download/mac

    2) Which lets you install Ruby via RVM (https://rvm.io/rvm/install/):
    $ curl -L https://get.rvm.io | bash -s stable --ruby

    3) Which lets you install Compass (http://compass-style.org/install/)

    1. $ gem update --system
    2. $ gem install compass

    4) Which is required for Sencha Cmd (SenchaCmd-3.0.0.250-osx.app)
    Reference: http://docs.sencha.com/touch/2-1/#!/guide/command
    Just use the defaults.

    http://www.sencha.com/products/sencha-cmd/download

    5) Which lets you install Sencha Touch 2.0 (sencha-touch-2.1.0-commercial)
    Reference: http://docs.sencha.com/touch/2-1/#!/guide/command
    Install into your ~/Sites for http://localhost/~<username>,
    or /Library/WebServer/Documents for internet sharing via http://localhost

    http://www.sencha.com/products/touch/