20 apr 12 just notes. made me feel better. I think you are aware of them all.
Here I put up a form with a combo box and connected it via ExtDirect.


added Direct store and model ok
plopped combo into form panel, set paths saved and deployed.
Loading forever. Chrome console says "Uncaught TypeError: Cannot read property 'directCfg' of undefined".
I had to fiddle with the store until the red light went out so I figured I was done.
Guess I'm not. Back to config. In the course of which I change the api itself.

Cursor turned to splitter and was hard to shake off. Mouseoff config scroller area maybe.

Had to exit and restart to get SA to reload the ExtDirect API.
I'm building my remoting api/servive in tandem.
Getting sorta okay now but still tons to learn.
Problems are gonna be anywhere.

From here I am lost. I am just barely getting comfortable with extjs itself,
so it really feels like the rug has been pulled out. Back to mystery land.
Both deploy and preview aren't working. I'm very sure it's something dumb
I have done. But I can't see any more. I'll have to take it back
to the standard environment to watch the network. SA was stopping before
that point because it didn't like my config, but I rather suspect the network.
Which I can't see without actually doing the post, which SA won't do for me.
At least I think that's right. I have to leave off because I need debugging.


No duh. Go look at the generated project. Here is the error:

===========================
constructor: function(cfg) {
var me = this;
cfg = cfg || {};
me.callParent([Ext.apply({
storeId: 'VCats',
model: 'MyApp.model.VCat',
proxy: {
type: 'direct',
api: read:ext_read,
reader: {
type: 'json'
}
}
}, cfg)]);
}
});
=====================
Not sure what the error is, but the syntax highlighter turned the screen into a Christmas tree.

Dunno how I messed it up, nor did SA seem unhappy. I deleted the config, reloaded and re-entered
and off we go. Now I'm getting "Cannot read property 'success' of undefined" okay I know
how to fix that.

Maybe not. I set my result,total and data fields, now the combo
is dropping down, but the rows are empty.

Expected to find drop down list of model fields for display name and value properties
on a combo box. Fiddled about until I got the right ones.

Adding a simple event was sweet, The code opened up and the prompt reminded
me of the args.

Whoa. Closing all them terminal windows is silly. Guess I deployed a bit carelessly

This 'app' folder remains a question in my mind. I think my folder/app structure/organizaton
might be different that what you expect or desire. But all examples are "hello world" style
where there just aren't enough files to really tell. But looks like SA absolutely
insists on ceating an 'app' folder?

This is going to be very slick guys. Thank you for your patience as I whine and rage and blather.

Documents, tutorials, examples, guidaance: keep em coming thanks!

===
A startup task is to enter all my models fields. Really don't wanna.
I already got a crud generator and stencil. I can bang out my whole database.
Is there any way I can generate something like this for you and paste it in?
(plus the model fields too). Just the basics to get started...

{
"id": "ExtBox1-ext-gen2830",
"type": "datafield",
"reference": {
"name": "fields",
"type": "array"
},
"codeClass": null,
"userConfig": {
"name": "list_id",
"type": "int",
"designer|userClassName": "MyField"
},
"customConfigs": [],
"expanded": true
},....
===