1. #1
    Ext JS Premium Member jvandemerwe's Avatar
    Join Date
    Apr 2009
    Location
    Raalte, Netherlands
    Posts
    47
    Vote Rating
    2
    jvandemerwe is on a distinguished road

      0  

    Default No Ext JS 3 support in Sencha Architect, let's get back to Designer 2.0 Beta

    No Ext JS 3 support in Sencha Architect, let's get back to Designer 2.0 Beta


    In Sencha Architect you can't make designs for Ext JS 3 anymore. This is understandible, but not nice. I have still a lot of legacy that sometimes needs to be extended. I know that upgrading it to Ext JS 4 would be much better, but since my customer doesn't want to invest in it now, nothing remains than stay in Ext JS 3 (with this customer that is).

    But as Architect doesn't support Ext JS 3 anymore, I thought I install Sencha Designer 2.0 Beta again. This works fine, except I can't register anymore. After entering my credentials, it keeps on running around in accepting the terms and conditions and asking for my credentials.

    How to act when you have bought Architect and still need Ext JS 3 functionality? Will Sencha drop Designer 2.0 for Architect? After using Designer so intensively, I feel a bit lost without it.

  2. #2
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,445
    Vote Rating
    129
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Sencha Designer 2.0 Beta did not support Ext JS 3 either.

    For users of Sencha Architect 2.0 that require Ext 3 support, we will gladly generate you a license for Ext Designer 1.2.x.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  3. #3
    Ext JS Premium Member jvandemerwe's Avatar
    Join Date
    Apr 2009
    Location
    Raalte, Netherlands
    Posts
    47
    Vote Rating
    2
    jvandemerwe is on a distinguished road

      0  

    Default Aaron, you are right

    Aaron, you are right


    You're right about that. I have digged up a version 1 and reinstalled it again, next to the Architect. That will do. Thank you for your reply.

  4. #4
    Sencha User
    Join Date
    Aug 2010
    Posts
    3
    Vote Rating
    0
    heilen is on a distinguished road

      0  

    Default Ext Designer license and download?

    Ext Designer license and download?


    Hi! I'm running a similar problem.

    We have an Ext Designer license and developed and app using it, we now want to migrate to Ext4 and bought the upgrade to Sencha Architect, in order to rewrite the app we want to use simultaneously Ext Designer and Sencha Architect (so that we can see what we have in one and replicate the design in the later).

    Is there anyway you can provide me with the download link for Ext Designer? (I guess I have the original license lying around in my email)

    Thanks!

    Heilen

  5. #5
    Sencha Premium Member
    Join Date
    Feb 2009
    Location
    Glasgow, Scotland
    Posts
    342
    Vote Rating
    12
    Stuart-SwarmOnline will become famous soon enough Stuart-SwarmOnline will become famous soon enough

      0  

    Default


    I'd like to bump this thread as I'm looking for a download link for Ext Designer 1.2 as I've just moved to a new computer so need to reinstall it...

    Thanks
    Stuart

  6. #6

  7. #7
    Ext JS Premium Member jvandemerwe's Avatar
    Join Date
    Apr 2009
    Location
    Raalte, Netherlands
    Posts
    47
    Vote Rating
    2
    jvandemerwe is on a distinguished road

      0  

    Default


    Great, thanks.

  8. #8
    Sencha User
    Join Date
    Aug 2010
    Posts
    3
    Vote Rating
    0
    heilen is on a distinguished road

      0  

    Default


    thanks!

  9. #9
    Sencha User
    Join Date
    Sep 2010
    Posts
    13
    Vote Rating
    0
    elentirmo is on a distinguished road

      0  

    Default


    Can you also provide download links for version 1.1? There are some bugs in 1.2 that prevent me from upgrading.

  10. #10