I can't find docs anywhere on how to use the legacy module. I'd like to get rid of my 2.2.5 dependency while I migrate. I've inherited it... now what? The jar doesn't seem to contain very much.