1. #1
    Sencha User
    Join Date
    Oct 2011
    Posts
    34
    Vote Rating
    0
    dakamojo is on a distinguished road

      0  

    Default Can't run in iOS Simulator

    Can't run in iOS Simulator


    I posted about this before but didn't get a resolution. I am working on this again. My main app won't run in the iOS Simulator. I get just a blank white screen.

    So I created a new Touch project (using build #412). In this project I drag in one Panel and I set the HTML to "Hello". It is marked as initialView by default. I click on Deploy and then fill in the values for the simulator.json file. I click on Save and Simulate and I get a white screen in the Simulator. The output on the console says this.

    Code:
    /var/folders/d5/277mgmg09mq99jjw5gvf5v5w000123/T/temp.sh ; exit;
    ddavismbp:~ darrelldavis$ /var/folders/d5/277mgmg09mq99jjw5gvf5v5w000123/T/temp.sh ; exit;
    sencha package run /Users/darrelldavis/Projects/SenchaProjects/Test1/simulator.json
    The application was successfully packaged
    Path: //Users/darrelldavis/build/Test1.app
    Device: iphone
    [DEBUG] 2012-04-25 10:10:25.861 stbuild_template[32097:17903] The requested URL was not found on this server.
    The current version of Architect creates an app.html file (used to be designer.html in previous versions). The version of SDK Tools I have I think expects app.html so I think that is correct I don't know how to tell if I have the current SDK Tools. Its just labeled "Beta".

    Curiously in my main app I do not get the error message about the URL, but I still only get a white screen.

    Any help?

  2. #2
    Ext JS Premium Member corcoranp's Avatar
    Join Date
    Apr 2007
    Location
    Pleasant Grove, AL
    Posts
    25
    Vote Rating
    3
    corcoranp is on a distinguished road

      0  

    Default


    Copy the app.html and rename it to index.html....

    Had this same issue, plus make sure you are pointed to the correct location in your deploy settings.
    Peter M Corcoran

    ExtJs Developer since 2007
    www.corcoranp.com
    http://www.linkedin.com/in/corcoranp

  3. #3
    Sencha User
    Join Date
    Oct 2011
    Posts
    34
    Vote Rating
    0
    dakamojo is on a distinguished road

      0  

    Default


    I copied app.html to index.html. Now I no longer get the invalid URL message. Now I just get a black screen in the Simulator.

    Then I figured it out. If I run "sencha package run simulator.json" from a terminal window, the app displays fine in the Simulator. Its only an issue when I run it from Architect.

Thread Participants: 1