Gelmiş geçmiş en büyük porno sitemiz olan 2pe de her zaman en kaliteli pornoları sunmayı hedefledik. Diğer video sitemiz olan vuam da ise hd porno ağırlıklı çalışmalara başladık.

  1. #1
    Sencha User
    Join Date
    Sep 2010
    Posts
    2
    Vote Rating
    0
    tjosten is on a distinguished road

      0  

    Default Answered: Ext.Loader autoloading issue

    Answered: Ext.Loader autoloading issue


    Hi,

    I am running into trouble with Ext.Loader. In my app.js, I define the Ext.Loader config and my application:

    Code:
    Ext.Loader.setConfig({
      enabled: true
    });
    Ext.Loader.setPath('kkCms', 'js/app');
    
    Ext.application({
      name: 'kkCms',
      autoCreateViewport: false,
      controllers: [
        'Login'
      ],
        
      launch: function() {
        console.log('launch: kkCms');
      }
    });
    Unfortunately, the autoloader seems to ignore my Ext.Loader settings. If i run the application, it looks for Login.js in app/controller/Login.js, although I defined another path for this namespace.

    On the other side, when I load the controller with Ext.require before the application launches..

    Code:
    Ext.require('kkCms.controller.Login');
    .. the app looks for Login.js at the right place (js/app/controller/Login.js)

    Personally, I thought the sense and purpose of Ext.Loader's autoloading functionality is to be lazy with Ext.require, as I think it is not really nice to require every single view, model, store and controller you need in your app, or is it?

    Thanks for your help.

  2. Loader is awesome.

    change your code to:
    Code:
    Ext.Loader.setConfig({
      enabled: true,
      paths : {
          kkCms : 'js/app'
      }
    });
    See if that fixes it.

  3. #2
    jay@moduscreate.com's Avatar
    Join Date
    Mar 2007
    Location
    Frederick MD, NYC, DC
    Posts
    16,353
    Answers
    102
    Vote Rating
    77
    jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all

      0  

    Default


    Loader is awesome.

    change your code to:
    Code:
    Ext.Loader.setConfig({
      enabled: true,
      paths : {
          kkCms : 'js/app'
      }
    });
    See if that fixes it.

Thread Participants: 1

Tags for this Thread