Success! Looks like we've fixed this one. According to our records the fix was applied for EXTJS-6081 in a recent build.
  1. #1
    Sencha User
    Join Date
    Jun 2008
    Posts
    298
    Vote Rating
    17
    Qtx will become famous soon enough

      0  

    Default [4.1.0] The field of the type 'hiddenfield' occupies the visile place in the form

    [4.1.0] The field of the type 'hiddenfield' occupies the visile place in the form


    REQUIRED INFORMATION


    Ext version tested:
    • Ext 4.1.0


    Browser versions tested against:
    • IE 9.0.8112.16421
    • FF 12.0, firebug 1.9.1
    • Opera 11.62
    • Chrome 18
    • Safari 5.1.5


    Description:
    • The field of the type 'hiddenfield' occupies the visible place in the form panel


    Steps to reproduce the problem:
    • Take the demo example field-types.js
    • Add the hidden field between the fields textfield1 and password1
    • View the example, there is now more free space between the fields textfield1 and password1


    The result that was expected:
    • The hidden field should no have any visible effects in the form panel


    The result that occurs instead:
    • The hidden field occupies the visible place in the form panel


    HELPFUL INFORMATION

    Debugging already done:
    • yes


    Possible fix:

    This override helps, but for real fixing, the rendering of the hidden field
    should investigated.

    Code:
    Ext.override(Ext.form.field.Hidden, {
    
      hidden: true
        
    });
    Additional CSS used:
    • only default ext-all.css


    Operating System:
    • Windows 7

  2. #2
    Sencha User ewi-stoe's Avatar
    Join Date
    Nov 2011
    Location
    Karlsruhe
    Posts
    4
    Vote Rating
    0
    ewi-stoe is on a distinguished road

      0  

    Default


    same here on a mac

    in addition i get in the console:
    XTemplate Error: maxLength is not defined @ext-all-dev.js:10974

    some more information:
    the hiddenfield is in a form panel with vbox layout and default flex: 1

    Code:
    // ...
    {
        xtype: 'formpanel',
        layout: {
            align: 'stretch',
            type: 'vbox'
        },
        defaults: {
            flex: 1,
            labelWidth: 150
        },
        items: [
            {
                xtype: 'hiddenfield',
                name: 'sender',
                value: 0
            }
            // ...
        ]
    }
    // ...

  3. #3
    Ext JS Premium Member
    Join Date
    Jan 2008
    Posts
    25
    Vote Rating
    1
    lmalgras is on a distinguished road

      0  

    Default


    For information, the possible fix by Qtx as no effect on the "XTemplate Error: maxLength is not defined"

  4. #4
    Sencha Premium Member
    Join Date
    Aug 2010
    Posts
    3
    Vote Rating
    0
    jrh0090 is on a distinguished road

      0  

    Default


    I was able to get the warnings to go away with this override of the template. The only thing I did was remove the maxLength field.
    Code:
    Ext.override(Ext.form.field.Hidden, {
            fieldSubTpl: [ // note: {id} here is really {inputId}, but {cmpId} is available
                '<input id="{id}" type="{type}" {inputAttrTpl}',
                ' size="1"', // allows inputs to fully respect CSS widths across all browsers
                '<tpl if="name"> name="{name}"</tpl>',
                '<tpl if="value"> value="{[Ext.util.Format.htmlEncode(values.value)]}"</tpl>',
                '<tpl if="placeholder"> placeholder="{placeholder}"</tpl>',
                '<tpl if="readOnly"> readonly="readonly"</tpl>',
                '<tpl if="disabled"> disabled="disabled"</tpl>',
                '<tpl if="tabIdx"> tabIndex="{tabIdx}"</tpl>',
                '<tpl if="fieldStyle"> style="{fieldStyle}"</tpl>',
                ' class="{fieldCls} {typeCls} {editableCls}" autocomplete="off"/>',
                {
                    disableFormats: true
                }
            ]
        });

  5. #5
    Ext JS Premium Member
    Join Date
    Jan 2008
    Posts
    25
    Vote Rating
    1
    lmalgras is on a distinguished road

      0  

    Default


    This bug is marked as fixed since Ext JS 4.1.1

  6. #6
    Sencha User
    Join Date
    Jun 2008
    Posts
    298
    Vote Rating
    17
    Qtx will become famous soon enough

      1  

    Default


    I noticed that this bug is still present in the ExtJS 4.2