Presenting a plugin that displays a nice message box to your users saying their browser is not supported Displays a nice list of alternatives you can configure yourself

Get it over @ https://github.com/Scorpie/Ext.ux.BrowserCheck and just look @ the index.html & Ext.ux.BrowserCheck.

This plugin actually consists of two parts; the actual detection of the browser (Ext.ux.BrowserDetect) and the notification part (Ext.ux.BrowserCheck).

For all options see Ext.ux.Browsercheck.js.

Images & Styling included.

Screenshot:

Ext.ux.BrowserCheck.jpg

Tested on ExtJS 4.0.7, Chrome, FF 12, Internet Explorer 9.
If you have any comments feel free to share