Gelmiş geçmiş en büyük porno sitemiz olan 2pe de her zaman en kaliteli pornoları sunmayı hedefledik. Diğer video sitemiz olan vuam da ise hd porno ağırlıklı çalışmalara başladık.

  1. #1
    Sencha User
    Join Date
    May 2012
    Location
    Weed, CA, US
    Posts
    18
    Answers
    2
    Vote Rating
    1
    justinzane is on a distinguished road

      0  

    Default Unanswered: How to allow browser to "remember" textfield values?

    Unanswered: How to allow browser to "remember" textfield values?


    Most browsers have a convience feature that "remembers" the last value(s) entered into a textfield. I've noticed that the Extjs 4 xtype: 'textfield' field I've been using do not trigger this browser feature. How can I enable/disable this browser convenience, especially for FF and Chrome, programatically?

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    8,862
    Answers
    651
    Vote Rating
    438
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      0  

    Default


    You will need to use a combo and simply hide the trigger ... something like:
    http://dev.sencha.com/deploy/ext-4.0...um-search.html

    Regards,
    Scott.

  3. #3
    Sencha User
    Join Date
    May 2012
    Location
    Weed, CA, US
    Posts
    18
    Answers
    2
    Vote Rating
    1
    justinzane is on a distinguished road

      0  

    Default


    No, perhaps I wasn't clear. I'm not concerned with "auto-suggest" type behavior like the example you showed. I'm talking about the browser's ability to store and later recall what the user types into <input type='text'...> fields.

    For example, go to craigslist.org and type "developer" into the search box. Later, whether after a simple back navigation or after weeks, when you revisit that box and start typing "d", the browser, NOT the site, will suggest "developer" from your form history.

    With Ext JS 4 xtype:"textfield" fields, this does not happen. Why?

  4. #4
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    8,862
    Answers
    651
    Vote Rating
    438
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      0  

    Default


    This is the same premise of what I mentioned, except that you would have to store the entries in a cookie and recall them in a dropdown list.

    Instead of loading suggested data from a server, you would load past entries from the cookie.

    Regards,
    Scott.

  5. #5
    Sencha User
    Join Date
    May 2012
    Location
    Weed, CA, US
    Posts
    18
    Answers
    2
    Vote Rating
    1
    justinzane is on a distinguished road

      0  

    Default


    Scott, thank you for your quick replies. You are, however, missing the point of my query. I, the ExtJS dev, do not want my SCRIPTS TO DO ANYTHING to recall values. My observation is that something in the way Ext wraps or styles <input....> fields is interfering with the way that the browser interacts with plain HTML <input name="foo" /> fields. I am trying to determine how to change a parameter on the xtype: "textfield" object OR on the various .sass settings related to textfields and forms so that the basic HTML browser behavior of storing a history of field entries will continue to occur.

    In short, I want to know how to STOP extjs from changing the basic html form <-> browser interaction.

  6. #6
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    8,862
    Answers
    651
    Vote Rating
    438
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      0  

    Default


    I understand.

    Since these are custom controls, you will have to provide this feature yourself. If there is a way to override this and provide the action you are looking for, as a default browser behavior, I am not aware of how to do this.

    Scott.

  7. #7
    Sencha User
    Join Date
    May 2012
    Location
    Weed, CA, US
    Posts
    18
    Answers
    2
    Vote Rating
    1
    justinzane is on a distinguished road

      0  

    Default


    Thanks. When I feel particularly ambitious, I'll take firebug and go through all the parent classes and CSS/SASS and see which particular element is changing the browser behavior. It is not critical, but I have learned to like that browser feature and I'm sure many users have as well.

  8. #8
    Ext JS Premium Member
    Join Date
    Jun 2010
    Posts
    18
    Vote Rating
    2
    nickelstar5 is on a distinguished road

      2  

    Default inputAttrTpl

    inputAttrTpl


    I was able to accomplish browser completion by using the inputAttrTpl config item on the textfield. Here's a sample login form that uses that idea to turn the input field's autocomplete attribute to "on":

    PHP Code:
    {
        
    "xtype""form",
        
    "height"135,
        
    "width"400,
        
    "defaults": {
            
    labelWidth75
        
    },
        
    "bodyCls""my-pnl",
        
    "bodyPadding"20,
        
    "title""Enter Your Account Credentials",
        
    "standardSubmit"true,
        
    "url""/site/login",
        
    "items": [
            {
                
    "xtype""textfield",
                
    "anchor""100%",
                
    "inputId""username",
                
    "inputAttrTpl": [
                    
    "autocomplete=\"on\""
                
    ],
                
    "name""username",
                
    "fieldLabel""User Name",
                
    "enableKeyEvents"true
            
    },
            {
                
    "xtype""textfield",
                
    "anchor""100%",
                
    "inputId""password",
                
    "inputAttrTpl": [
                    
    "autocomplete=\"on\""
                
    ],
                
    "inputType""password",
                
    "name""password",
                
    "fieldLabel""Password",
                
    "enableKeyEvents"true
            
    },
            {
                
    "xtype""button",
                
    "iconCls""icon-arrow-right",
                
    "text""Log In"
            
    }
        ]


  9. #9
    Sencha User
    Join Date
    May 2012
    Location
    Weed, CA, US
    Posts
    18
    Answers
    2
    Vote Rating
    1
    justinzane is on a distinguished road

      0  

    Default


    Works well for the plain text fields for me. Does not trigger the "Do you want to save this password?" browser query on the password field.

    Thanks, though.

  10. #10
    Sencha User
    Join Date
    Jan 2009
    Posts
    9
    Vote Rating
    0
    blagerweij is on a distinguished road

      0  

    Default


    1) Override default ExtJS Textfield behavior for autocomplete (copied from lagnat):

    Code:
    Ext.define('ACField', {
        extend: 'Ext.form.field.Text',
    
        initComponent: function() {
            Ext.each(this.fieldSubTpl, function(oneTpl, idx, allItems) {
                if (Ext.isString(oneTpl)) {
                    allItems[idx] = oneTpl.replace('autocomplete="off"', 'autocomplete="on"');
                }
            });
            this.callParent(arguments);
        }
    });
    2) Make sure the textfields are within a <form> tag: (see answer from lagnat), since ExtJS 4 the<form> tag is no longer present in a FormPanel.

    Code:
    autoEl: {
            tag: 'form',
            action: '/j_spring_security_check',
            method: 'post'
        },
    3) Make sure there is a <form> present in the HTML, with the same <input> names:

    Code:
    items:[
                    Ext.create('ACField',{
                        fieldLabel: 'Username',
                        name:'j_username',
                        inputId: 'username',
                        allowBlank:false,
                        selectOnFocus:true
                    }),
                    Ext.create('ACField',{
                        fieldLabel:'Password',
                        name:'j_password',
                        inputId: 'password',
                        xtype:'textfield',
                        allowBlank:false,
                        inputType:'password'
                    })
                ],
    and within the HTML the regular form with same input names:

    Code:
    <body>
    <div id="login-panel">
        <form id="loginForm" action="<c:url value="/j_spring_security_check"/>" method="post">
            <input class="x-hidden" type="text" id="username" name="j_username"/>
            <input class="x-hidden" type="password" id="password" name="j_password"/>
        </form>
    </div>
    <noscript>Please enable JavaScript</noscript>
    </body>
    With all these changes in place, saving username/password works in IE, Chrome and Firefox.

    Barry