1. #1
    Sencha User
    Join Date
    Jun 2012
    Posts
    1
    Vote Rating
    0
    arii is on a distinguished road

      0  

    Default Unanswered: Display issue on TabPanel with GXT3

    Unanswered: Display issue on TabPanel with GXT3


    Hi,

    I have a strange problem with an application of tabPanel:
    This is my code (for example) :


    public class Zone3ViewImpl implements Zone3View {

    private TabPanel tabPanel;

    public Zone3ViewImpl() {
    tabPanel = new TabPanel();
    tabPanel.setBodyBorder(false);
    tabPanel.setTabScroll(true);

    tabPanel.add(new Label("Tab 1 Content"), new TabItemConfig("Tab 1", true));
    tabPanel.add(new Label("Tab 2 Content"), new TabItemConfig("Tab 2", true));

    }


    @Override
    public Widget asWidget() {
    return tabPanel;
    }

    }

    And the display of Zone3ViewImpl in my application looks like this :
    tabPanel.jpg

    As you can see, the first Tab isn't display at the left of my window and all my tabs got an enlarge "header".
    Impossible to see where the problem come from.

    If someone can help me, I would really appreciate it.

    thx

  2. #2
    Sencha User
    Join Date
    Jul 2012
    Posts
    4
    Vote Rating
    0
    kourian is on a distinguished road

      0  

    Default


    Hi,

    Did you find a way to fix this?

    I Have the exact same problem using tabs.
    I tried the sample code in the explorer with gxt 3.0.0b and I have an extra 40px padding on the left and a height of 46px (21px on the explorer).

    Can somoene explain us why we have this weird display.

    Thanks

  3. #3
    Sencha - GXT Dev Team
    Join Date
    Feb 2009
    Location
    Minnesota
    Posts
    2,732
    Answers
    109
    Vote Rating
    90
    Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light Colin Alworth is a glorious beacon of light

      0  

    Default


    As mentioned also in http://www.sencha.com/forum/showthread.php?198415, it appears that you are not loading the reset.css file correctly. Either it is missing in your html page, or is not loading when the application comes up correctly - the Chrome Inspector should show a 404 if it is not loading correctly.

  4. #4
    Sencha User
    Join Date
    Jul 2012
    Posts
    4
    Vote Rating
    0
    kourian is on a distinguished road

      0  

    Default


    Thank you very much for your quick answer.
    I didn't get any 404 on reset.css on firebug.
    I added it and it has fixed the rendering.

Thread Participants: 2

Tags for this Thread