1. #1
    Sencha User
    Join Date
    Apr 2010
    Posts
    107
    Vote Rating
    -1
    merrells is an unknown quantity at this point

      0  

    Default SIO SDK 0.3.3 Released

    SIO SDK 0.3.3 Released


    We just updated the SDK and the documentation.

    http://docs.sencha.io/0.3.3/index.html


    http://download.sencha.io/sencha-io-0.3.3.zip

    This update includes some example applications, and improvements to the API documentation and to the guides.

    The release notes include a list of changes since the last release.

    http://docs.sencha.io/0.3.3/index.ht.../release_notes


    Post to the forum, or email me, if you experiemce any problems. merrells@sencha.com

    John

  2. #2
    Sencha User
    Join Date
    Feb 2012
    Posts
    69
    Vote Rating
    2
    deshartman is on a distinguished road

      0  

    Default Compatibility Error with Sencha 2.0.1.1

    Compatibility Error with Sencha 2.0.1.1


    I just downloaded 0.3.3 io and using sencha touch 2.0.1.1

    Get the following error:

    ERROR: The Sencha.io SDK requires either the Sencha Touch SDK or the Sencha Ext JS SDK. Version 2.0.1.1 of the Sencha Touch SDK and this version of the Sencha.io SDK are not fully compatible. in Overides.js:121

    I added the following lines to app.json

    Code:
    "js": [
    <snip>
          // Added this section for Sencha IO
            {
                "path": "sencha-io-0.3.3/lib/socket.io.js"
            }
    ],
    I added the following lines to app.js

    Code:
    // Added for Sencha.io
    Ext.Loader.setPath({
        'Ext.io': 'sencha-io-0.3.3/src/io',
        'Ext.cf': 'sencha-io-0.3.3/src/cf'
    });
    
    Ext.application({
    <snip>
    
       io: {
            appId: "XXXXX",
            appSecret: "XXXXXXXX",
        },

  3. #3
    Sencha - Training Team mrsunshine's Avatar
    Join Date
    Sep 2008
    Location
    Germany - Darmstadt
    Posts
    690
    Vote Rating
    12
    mrsunshine will become famous soon enough

      0  

    Default


    2.0.1.1 is not in the version compatible list check yet, i guess they will at it with the next version

  4. #4
    Sencha User
    Join Date
    Apr 2010
    Posts
    107
    Vote Rating
    -1
    merrells is an unknown quantity at this point

      0  

    Default


    Hello,

    Yes, SIO checks for ST 2.0.1. We haven't certified SIO with ST 2.0.1.1 yet, but very little changed, so it should work. You can edit the code that checks. Search and replace 2.0.1 to 2.0.1.1.

    John

  5. #5
    Ext JS Premium Member
    Join Date
    Nov 2009
    Location
    St Louis,MO
    Posts
    267
    Vote Rating
    18
    James Goddard will become famous soon enough James Goddard will become famous soon enough

      1  

    Default


    So it's 24 days later and you still haven't validated your product with your other product it is required to use? IO is beta, so it is acceptable to have bugs. So which is the better course:

    1. Release your Beta product that is expected to have bugs and allow it to work with the shipping version of the sdk that "should work".
    2. Release your a Beta product that refuses to run at all.

    Instead you ask all of your users to edit your source code so that your products work and play well together?
    The least you could do is change the check to a Warning instead of stopping all execution.

    Come on guys. When you had 2 products there was a lot of quality, but the 8 you have going now are all suffering...

    Oh and it also doesn't work with the current ExtJS...

  6. #6
    Sencha User
    Join Date
    Apr 2010
    Posts
    107
    Vote Rating
    -1
    merrells is an unknown quantity at this point

      0  

    Default


    Hello James,

    We just released SIO SDK 0.3.4, which includes supports for all versions of Sencha Touch from 2.0 through to 2.1.

    John