Hybrid View

  1. #1
    Sencha User
    Join Date
    Apr 2012
    Posts
    1
    Vote Rating
    0
    llupien is on a distinguished road

      0  

    Default Choppy sometimes in iPad

    Choppy sometimes in iPad


    I am doing animations involving going from screenshot to screenshot in individual scenes. This is so we can "simulate" a software task for a learning environment. It involves mostly, besides the screenshots of the software at various points, textboxes with instructions for the student and hotspots to move to next scene, etc. Mostly really really simple.

    We are making these into widgets to run on iPads in iBooks. Once in a while, one of these animations seems to get sort of jumpy or choppy - between scenes (and screenshot images). The browser (well, ibooks widget thingie) goes blank before you see the next screenshot. What could be causing this? Is there a preloading that happens with Sencha outputs, and if not would a preloading of the images help? Am I missing something in the timeline (a keyframe, etc) that I should make sure is there? Just trying to troubleshoot this.

    Thanks!

  2. #2
    Sencha User arnebech's Avatar
    Join Date
    Jun 2010
    Posts
    498
    Vote Rating
    10
    arnebech will become famous soon enough

      0  

    Default


    So when an animation loads, it typically loads all images (although some of them are hidden from the user). When switching scenes old images are hidden and new images are displayed, so what you see as a glitch might the iPad moving around images in the memory and or the GPU.

    To see if you can pinpoint a particular issue, you could try to reduce the image dimensions or the number of images in a project, and perhaps try to force close all other apps.

Thread Participants: 1

Tags for this Thread