1. #1
    Ext JS Premium Member
    Join Date
    Feb 2011
    Posts
    23
    Vote Rating
    0
    khkiley is on a distinguished road

      0  

    Default Force a full deploy ?

    Force a full deploy ?


    How can this be done ?

    I blew away all the files in the deploy directory and SA wont push all the files out.

    I assume it deploys incrementally, so how do i tell it to deploy all ?

    Thanks,

    Kurt

  2. #2
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,911
    Vote Rating
    63
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    It should do a full deploy if no files exist. Can you give us OS and the deploy command that's running?
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team

  3. #3
    Ext JS Premium Member
    Join Date
    Feb 2011
    Posts
    23
    Vote Rating
    0
    khkiley is on a distinguished road

      0  

    Default Here you go-

    Here you go-


    C:\Program Files (x86)\SenchaArchitect>xcopy "C:\Users\KURTY\Desktop\Sencha Projects\AA_PRE_QuoteTemplate" "\PRE-TEST-APP\QuoteSystem" /exclude:C:\Users\KURTY\AppData\Local\Temp\exclude.txt /s /e /y /d /i 0 File(s) copied


    I'm running a Windows 7 client.

    Thank you for your assistance.

  4. #4
    Ext JS Premium Member
    Join Date
    Feb 2011
    Posts
    23
    Vote Rating
    0
    khkiley is on a distinguished road

      0  

    Default


    Some more information. This is deploying to a server share, but the copy is not truly happening. Just noticed file date and times were not updating, and file contents were not changing. I've been deploying locally and copying to server manually, just started deploying directly to this server.

    It does not error out while deploying, but the copy is not happening.

    Thanks,

    Kurt

  5. #5
    Ext JS Premium Member
    Join Date
    Feb 2011
    Posts
    23
    Vote Rating
    0
    khkiley is on a distinguished road

      0  

    Default


    I changed back to deploying locally to my laptop and that works. If I delete the generated files then it recreates them as expected.

    I suspect now my problem is with Architect accessing the network share. It must be silently failing during the read as well as the deploy.

    So right now I cannot deploy to this network share. I can browse and open files without a problem.

  6. #6
    Ext JS Premium Member
    Join Date
    Feb 2011
    Posts
    23
    Vote Rating
    0
    khkiley is on a distinguished road

      0  

    Default


    I mapped a drive to the share and now it work through the mapped drive.

    Kurt

  7. #7
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,911
    Vote Rating
    63
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    Kurt,

    Nice debugging and getting this to work.

    I'm guessing it's a xcopy issue that your resolved.
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team

Thread Participants: 1