1. #1
    Sencha User
    Join Date
    Feb 2011
    Posts
    111
    Vote Rating
    0
    sissonb is on a distinguished road

      0  

    Default SDK directory not recognized

    SDK directory not recognized


    I am working on a Windows 7 64 bit machine I've installed the SDK to c:/senchasdk When I try to run the command, "sencha app create MyApp c:/www/testapp", get the following error.

    [ERROR] The current working directory (c:\senchasdk) is not a valid SDK directory. Please 'cd' into a SDK directory before executing this command.
    Here's a video of the issue,
    http://screencast.com/t/4tb7nVO6K

    Any ideas why this is happening?

  2. #2
    Ext JS Premium Member
    Join Date
    Apr 2009
    Posts
    9
    Vote Rating
    2
    domino6 is on a distinguished road

      1  

    Default


    I have exactly the same problem.

  3. #3
    Sencha User
    Join Date
    Nov 2012
    Posts
    2
    Vote Rating
    0
    Tzvika.m is on a distinguished road

      0  

    Default me 3

    me 3


    I have the same issue exactly.
    there must be some fix to this...

  4. #4
    Sencha User
    Join Date
    Nov 2012
    Posts
    2
    Vote Rating
    0
    Tzvika.m is on a distinguished road

      0  

    Default


    I fount the problem, it turns out you can't use sdk tools with sencha touch 2.1.0,
    you need to use sencha cmd

    funny that in the documentation that comes with sencha touch 2.1.0 it says to use the sdk tools...

  5. #5
    Sencha User
    Join Date
    Dec 2009
    Posts
    95
    Vote Rating
    0
    Wolfie is on a distinguished road

      0  

    Default


    can anybody tell me what is going on here ?

    I have sencha touch 2.1 and SenchaSDKTools 2.0.0 beta3.

    I have the same issue, no mater from where I am running "sencha" command - it doesn't work from SenchaSDKTools nor from unziped senchaTouch2.1 folder on my http server.

    I am fighting with this over 4 hours and nothing.
    Please help

  6. #6
    Sencha User
    Join Date
    Dec 2009
    Posts
    95
    Vote Rating
    0
    Wolfie is on a distinguished road

      0  

    Default


    Yes, I have found, that you can use sencha touch 2.0.0 with senchaSDKTools 2.0.0 beta3, but for me is not a resolved issue.

    I want to use sencha 2.1 with senchaSDKTools, any ideas ?

  7. #7
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Posts
    1,365
    Vote Rating
    135
    dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold dongryphon is a splendid one to behold

      0  

    Default


    Sencha Touch 2.1 requires Sencha Cmd v3. Sorry for the confusion.
    Don Griffin
    Ext JS Development Team Lead

    Check the docs. Learn how to (properly) report a framework issue and a Sencha Cmd issue

    "Use the source, Luke!"