Success! Looks like we've fixed this one. According to our records the fix was applied for EXTGWT-2246 in a recent build.
  1. #1
    Ext GWT Premium Member
    Join Date
    Aug 2010
    Location
    Germany, Solingen
    Posts
    239
    Vote Rating
    2
    gishmo is on a distinguished road

      0  

    Default GXT 3.0.0b - HtmlEditor.setEnable(false) does not work

    GXT 3.0.0b - HtmlEditor.setEnable(false) does not work


    If HtmlEditor is disabled by calling setEnable(false), the widget gets the disabled appearance.
    But it is till possible to edit the text and to use the editor tool.

    I would expect, that it is not possible to edit the text and all editor tools are disabled.

  2. #2
    Sencha User WesleyMoy's Avatar
    Join Date
    Oct 2009
    Location
    Redwood City, California
    Posts
    402
    Vote Rating
    2
    WesleyMoy is on a distinguished road

      0  

    Default


    Thanks for the report. This is certainly not the desired behaviour. I've filed a ticket against the team and will update this thread once we have a fix.

  3. #3
    Sencha - GXT Dev Team darrellmeyer's Avatar
    Join Date
    May 2007
    Location
    Washington, DC
    Posts
    2,242
    Vote Rating
    2
    darrellmeyer is on a distinguished road

      0  

    Default


    This still issue still exists in some versions of FF. HtmlEditor uses the GWT RichTextArea internally which has a known bug. See http://code.google.com/p/google-web-...detail?id=1488. Please star the GWT issue to get it bumped up to be fixed.

Thread Participants: 2