Wait! Looks like we don't have enough information to add this to bug database. Please follow this template bug format.
  1. #11
    Sencha Premium Member
    Join Date
    Jan 2010
    Posts
    5
    Vote Rating
    0
    msowka is on a distinguished road

      0  

    Default Workaround

    Workaround


    I had a detailed explanation of the cause for this and workaround, but it did not make it through the forum 'spam' filter / moderation (moderators, hello?).

    I will repeat in short so that people aren't banging their heads against the wall any longer on this, in bullet point form (maybe that will less resemble spam ):

    - Chrome introduced a feature just this summer for native touch interpretation on desktop browsers, having this enabled breaks sencha's desktop recognition of touch events. This is were the fix should happen, in the Sencha bootstrap logic (?); everything that follows here is a workaround.

    - This feature automatically detects touch devices on windows* and enables native touch interpretation. On chrome stable stream (v24) there is no way to force disable these; but you can start chrome without touch device, then connect the device and see touchmove events in sencha...

    - ... or use a development stream of chrome (I used Canary build, ~ v26*) which have triple-dropdown in about:flags that lets you explicitly disable 'Enable touch events'. This fixes any issues in sencha touch, but of course break touch interaction on compliant pages... this is a workaround.

    My 2c contribution to the investigation here.

    * my experiences is limited to win32, lets confirm this with os x / linux, and other versions of cutting edge chrome (beta & dev streams)

  2. #12
    Touch Premium Member
    Join Date
    Oct 2011
    Posts
    7
    Vote Rating
    0
    mmarchesi@xtel.it is on a distinguished road

      0  

    Default Any updates

    Any updates


    Any update on this matter?

    There is a workaround for this problem?