Looks like we cannot reproduce this. Please provide another test case to reproduce this issue.
  1. #1
    Sencha User
    Join Date
    Dec 2011
    Posts
    1
    Vote Rating
    0
    LeandroSe is on a distinguished road

      0  

    Default Chrome in iOS (autoMaximize)

    Chrome in iOS (autoMaximize)


    REQUIRED INFORMATION
    • sencha-touch-2.0.1.1
    Browser versions tested against:
    • Chrome 19.0.1084.60 (iOS)
    Description:

    The problem happens when i call the function autoMaximize within viewport in app.js file in the Chrome for iOS.

    The result that was expected:

    Hide Address Bar.

    The result that occurs instead:

    Application stopped.

    Code:

    Code:
    Ext.application({
    ...
        viewport : {
            autoMaximize : true
        },
    ...
    };

  2. #2
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    36,994
    Vote Rating
    846
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    Can I get a test case? This is working just fine for me:

    Code:
    Ext.application({
        name : 'Test',
    
        viewport : {
            autoMaximize : true
        },
    
        launch : function() {
    
            var number = 0;
            
            new Ext.Container({
                fullscreen : true,
                tpl        : 'Still working? {num}',
                data       : [
                    {
                        num : number
                    }
                ],
                items      : [
                    {
                        xtype : 'toolbar',
                        docked : 'top',
                        items  : [
                            {
                                text    : 'Test',
                                handler : function(button) {
                                    var cnt = button.up('container[fullscreen]');
            
                                    ++number;
            
                                    cnt.setData({
                                        num : number
                                    });
                                }
                            }
                        ]
                    }
                ]
            });
    
        }
    });
    Do note that it doesn't look like Chrome will be able to hide the address bar via this setting.
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  3. #3
    Sencha User
    Join Date
    Jan 2011
    Posts
    28
    Vote Rating
    0
    Null can only hope to improve

      0  

    Default not working on iphone 3gs with Chrome

    not working on iphone 3gs with Chrome


    Hi
    I can confirm the code above DOESNT work on Iphone 3gs (fw 5.0.1) with the Chrome iOS browser.
    A clean app, copy and pasted from above, if I set:

    Code:
     viewport : {
            autoMaximize : false
        },
    it works, but

    Code:
     viewport : {
            autoMaximize : true
        },
    doesnt work

    Is this a bug? or there any workarounds, like say detecting the Chrome app and not setting fullscreen or something....?

  4. #4
    Sencha User
    Join Date
    Jan 2011
    Posts
    28
    Vote Rating
    0
    Null can only hope to improve

      0  

    Default


    I notice this doesnt work either:

    http://www.sencha.com/forum/showthre...false&p=861977

  5. #5
    Sencha User
    Join Date
    Jan 2011
    Posts
    28
    Vote Rating
    0
    Null can only hope to improve

      0  

    Default


    ANyone else experience this?

  6. #6
    Sencha User
    Join Date
    May 2012
    Posts
    4
    Vote Rating
    0
    frecciadelsud836 is on a distinguished road

      0  

    Default


    Same problem for me...!

  7. #7
    Sencha User
    Join Date
    Jan 2011
    Posts
    28
    Vote Rating
    0
    Null can only hope to improve

      0  

    Default


    I notice as well, if I put automaximize to true the app will load in iOS safari by just going straight to url. HOWEVER, if I search google for my site, and click the link from there it looks like its going to load (fullscreen) but then never loads.
    Oddly, if I set automaximize to false it all loads fine across the board

  8. #8
    Sencha User
    Join Date
    Jan 2011
    Posts
    28
    Vote Rating
    0
    Null can only hope to improve

      0  

    Default


    Anyone?

  9. #9
    Sencha User
    Join Date
    Nov 2012
    Posts
    3
    Vote Rating
    0
    Xarem is on a distinguished road

      0  

    Default


    me too

    iOS 6.0.1
    Google Chrome v21.0.1180.82

    Easy test case: create an app which loads an Ext.NavigationView and create app.js with the following code -

    PHP Code:
    Ext.application({

        
    viewport : {        autoMaximizetrue    },        launch: function() {        Ext.Viewport.add({            xtype'main'        });    }    }); 
    with weinre client i only see a lot of this request:
    https://localhost:0/chromecheckurl

    No error or something.

  10. #10
    Sencha User
    Join Date
    Nov 2011
    Location
    Winterthur, Switzerland
    Posts
    22
    Vote Rating
    1
    tschortsch is on a distinguished road

      1  

    Default Browser detection

    Browser detection


    I had the same problem described in this thread. But I think with the following browser detection query it should work:

    Code:
    autoMaximize: (navigator.userAgent.search("Safari") !== -1 && navigator.userAgent.search("CriOS") === -1 && (!Ext.browser.is.Standalone && Ext.os.is.iOS && Ext.browser.version.isGreaterThan(3) ) ? true : false)
    navigator.userAgent.search("Safari") !== -1 -> true for Safari browser (also true for iOS Chrome)
    navigator.userAgent.search("CriOS") === -1 -> true for Safari browser but false for iOS Chrome browser (see https://developers.google.com/chrome...ocs/user-agent)