Gelmiş geçmiş en büyük porno sitemiz olan 2pe de her zaman en kaliteli pornoları sunmayı hedefledik. Diğer video sitemiz olan vuam da ise hd porno ağırlıklı çalışmalara başladık.

  1. #1
    Sencha Premium Member
    Join Date
    Jun 2012
    Posts
    21
    Vote Rating
    1
    bgeiger is on a distinguished road

      0  

    Default Line chart not showing line

    Line chart not showing line


    I'm trying to make a line chart with an xml store. Everything almost works, except I don't get a line. My axes are changing based on the data in my xml (so, for example, if my y variable goes from 0 to 25, it will show a different axis range than if my data goes from 0 to 100). So I know the store is working properly. I presume that the problem is in my line series, but I can't quite get it to do what I want.

    Here's a snippet from my view code:
    Code:
                               items: [
                                    {
                                        xtype: 'chart',
                                        height: 250,
                                        id: 'TelemetryChart',
                                        width: 400,
                                        animate: true,
                                        insetPadding: 20,
                                        store: 'TelemetryHistoryStore',
                                        axes: [
                                            {
                                                type: 'Numeric',
                                                fields: [
                                                    'speed'
                                                ],
                                                position: 'left',
                                                title: 'Speed'
                                            },
                                            {
                                                type: 'Time',
                                                fields: [
                                                    'time'
                                                ],
                                                position: 'bottom',
                                                title: 'Time',
                                                dateFormat: 'H:i',
                                                step: [
                                                    'mi',
                                                    5
                                                ],
                                                groupBy: 'day,hour,minute'
                                            }
                                        ],
                                        series: [
                                            {
                                                type: 'line',
                                                title: 'SpeedSeries',
                                                xField: 'time',
                                                yField: [
                                                    'speed'
                                                ]
                                            }
                                        ]
                                    }
                                ]
                            },
    Here's my XML:
    Code:
    <?xml version="1.0" encoding="UTF-8"?><Histories xmlns="http://example.org">
        <History>
            <time>2012-07-16 12:06:30</time>
            <speed>25</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:07:30</time>
            <speed>35</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:08:30</time>
            <speed>105</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:09:30</time>
            <speed>25</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:10:30</time>
            <speed>35</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:11:30</time>
            <speed>105</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:12:30</time>
            <speed>25</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:13:30</time>
            <speed>35</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:14:30</time>
            <speed>105</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:15:30</time>
            <speed>25</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:16:30</time>
            <speed>35</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
        <History>
            <time>2012-07-16 12:17:30</time>
            <speed>105</speed>
            <soc>100</soc>
            <generatorState>1</generatorState>
            <mpgge>55</mpgge>
        </History>
    </Histories>
    And here's what I'm seeing:
    Screen Shot 2012-07-20 at 2.17.22 PM.png

    Hopefully I'm just doing something done. I've tried several variations on the xField and yField, which seem like they'd be the culprits, but nothing's quite worked yet.

    Thanks for any help,

    Brian

  2. #2
    Sencha Premium Member
    Join Date
    Jun 2012
    Posts
    21
    Vote Rating
    1
    bgeiger is on a distinguished road

      0  

    Default


    So, no thoughts on this? Change a 0 to a 1? Missing a semicolon? Anything?