1. #1
    Sencha User
    Join Date
    Oct 2011
    Posts
    4
    Vote Rating
    0
    steveids is on a distinguished road

      0  

    Default Architect 2.1 Doesn't Run Preview in Fedora 16 with KDE

    Architect 2.1 Doesn't Run Preview in Fedora 16 with KDE


    OK, I ran SA from the prompt and when attempting to preview, it complains with:
    Cannot mix incompatible Qt library (version 0x40802) with this library (version 0x40800)
    dumps core and abends the preview thread.

    I'm on Fedora 16 with a current update of KDE (4.8.4).

    Now somebody appears to be too sensitive with the versions here. Or some update did not go through properly.

    Googling dug up this reply on the kde forum
    (
    http://forum.kde.org/viewtopic.php?f=63&t=101630):
    It is probable your application has a RPATH set in it, meaning it internally has paths stored toward the recommended libraries to use. Have you tried rebuilding your application after changing LD_LIBRARY_PATH?

    Of course I did not compile but Sencha did so maybe this will help someone.

  2. #2
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD.
    Posts
    1,745
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Hi steveids,

    I installed Fedora 16 KDE vanilla, and Architect runs okay. I did however check the Qt libs installed on the system and they were 4.8.0 (0x40800). Did you do a system update for Fedora 16? I'm going to try to do a system update to see if I am updated to 4.8.2 Qt libs (0x40802) and try to recreate the problem.

    Thanks.

  3. #3
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD.
    Posts
    1,745
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Quote Originally Posted by steveids View Post
    I'm on Fedora 16 with a current update of KDE (4.8.4).
    Ahh ok, let me update and try again.

  4. #4
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD.
    Posts
    1,745
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Interestingly enough, I upgraded Qt libs to 4.8.2 and the application still runs okay. I'm doing a full system update right now (including KDE 4.8.4) and will let you know what I experience.

  5. #5
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD.
    Posts
    1,745
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    I seem to be having no trouble running Sencha Architect 2.1 in a fully updated Fedora 16 w/ KDE.

    http://cl.ly/image/0l3p1T0T3Z2a

    Any other information you can share that might help? When you say you ran it from the prompt, do you mean you ran it in the same way as I did in the above screenshot? Did you try (with no success) running it from the Desktop shortcut?

    Hoping we can figure out what is going on here, as my environment is clearly not experiencing any conflicts. Maybe there's some third-party software getting in the way...

  6. #6
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD.
    Posts
    1,745
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Preview in Architect 2.1 issue

    I thought I'd make sure you got the fact that I had left out that SA 2.1 crashes when running preview.

    From thread:
    http://www.sencha.com/forum/showthre...ra-16-with-KDE
    Hi steveids,

    Ok this is news to me, I wasn't clear on the matter of only the Preview function experienced an issue. Looking into this, thanks.

  7. #7
    Sencha - Desktop Packager Dev Team jarrednicholls's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD.
    Posts
    1,745
    Vote Rating
    7
    jarrednicholls will become famous soon enough jarrednicholls will become famous soon enough

      0  

    Default


    Preview will open the application in the default browser on the system. To do this on KDE, we use the "kde-open" program, which seems to be the cause of the issue. This program is analogous to "start" on Windows, "open" on OS X and "xdg-open" on most Linux/Gnome systems.

    kde-open opens as a child process and attempts to pull in different Qt libs that are incompatible, and then crashes. Looks like this will be a KDE-only issue. Thanks for reporting it, we'll look into a solution.

  8. #8
    Sencha User
    Join Date
    Oct 2011
    Posts
    4
    Vote Rating
    0
    steveids is on a distinguished road

      0  

    Default


    I discovered the issue running from the menu entry. Then to see the error msg I ran it from the prompt.
    We have the issue on two different computers one having Fedora 16 (KDE) with Chrome as the default browser and the other with Fedora 15 (KDE) and Firefox.

    Appreciate your help!

Thread Participants: 1

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar