I agree but little too late for Ext JS 4