Hi,

I developed an App which works on difference browsers (no javascript errors...).
I'm trying to package it with Sencha Architect 2.1.
The version of my Android SDK tools is SDK Tools beta 3.

1) If i package my app in debug mode :
{
"applicationName": "MyApp",
"applicationId": "com.myapplicationID",
"bundleSeedId": "myBundleID",
"versionString": "1.0",
"iconName": "icon.png",
"inputPath": "/path/to/input",
"outputPath": "/path/to/output",
"configuration": "Debug",
"platform": "Android",
"deviceType": "Universal",
"certificatePath": "/path/to/myCertificate",
"certificateAlias": "MyCertificateAlias",
"sdkPath": "path/to/myAndroidSDK",
"androidAPILevel": "15"
}

Everything works but when i test it on emulator or device, i get a white screen. Nothing work while it works on browsers (Safari, Chrome)

2) If i package my app in release mode :
{
"applicationName": "MyApp",
"applicationId": "com.myapplicationID",
"bundleSeedId": "myBundleID",
"versionString": "1.0",
"iconName": "icon.png",
"inputPath": "/path/to/input",
"outputPath": "/path/to/output",
"configuration": "Debug",
"platform": "Android",
"deviceType": "Universal",
"certificatePath": "/path/to/myCertificate",
"certificateAlias": "MyCertificateAlias",
"sdkPath": "path/to/myAndroidSDK",
"androidAPILevel": "15"
}


Sencha architect say that my config file has no certificate password. How to set it with Sencha Architect ?

3) When i try to use sencha command line with a release configuration:
{
"applicationName": "MyApp",
"applicationId": "com.myapplicationID",
"bundleSeedId": "myBundleID",
"versionString": "1.0",
"iconName": "icon.png",
"inputPath": "/path/to/input",
"outputPath": "/path/to/output",
"configuration": "Debug",
"platform": "Android",
"deviceType": "Universal",
"certificatePath": "/path/to/myCertificate",
"certificatePassword":"coze67",
"certificateAlias": "MyCertificateAlias",
"sdkPath": "path/to/myAndroidSDK",
"androidAPILevel": "15"
}




i get this error :
jarsigner error: java.lang.RuntimeException: keystore load: Invalid keystore format
Could not sign application with error: 256

Could you tell me what is the right way to correctly package an app for Android ?

Best regards,

Nos