Eclipse 4.2 and 4.3 user can try my plugin: http://zulus.github.com/extjs-eclipse

It's on BSD license.
Current version support basic code assist.