You found a bug! We've classified it as DSGNR-2452 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha Premium Member
    Join Date
    Apr 2011
    Posts
    52
    Vote Rating
    1
    rh_it is on a distinguished road

      0  

    Default Option in CodeEditor for tab to always insert tab rather than indent line

    Option in CodeEditor for tab to always insert tab rather than indent line


    hello everybody I noticed that the indent code doesn't work well. Or maybe do I something wrong, does anybody confirm me that?
    When I try to indent with tabspace, for example after the equals sign, the entire code line moves right. I would love use common tabspaces instead common annoying spaces.

  2. #2
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,198
    Vote Rating
    120
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Could you please clarify?

    Did you change the spaces to indent configuration to "Tab"?
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  3. #3
    Sencha Premium Member
    Join Date
    Apr 2011
    Posts
    52
    Vote Rating
    1
    rh_it is on a distinguished road

      0  

    Default


    nope, If I want to indent a single code line
    For example:
    Code:
    var dummy                                 = "1234";
    and after the variable i use the tab it insert the tabspaces at the begin of the line and not after the equal mark:
    Code:
                                    var dummy = "1234";
    Do I something wrong? or should I set something in the preferences.
    Thanks anyway

  4. #4
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,198
    Vote Rating
    120
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    No, this is by design in the code editor that tab triggers indentation.

    We can look into adding an option to turning this off.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  5. #5
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,198
    Vote Rating
    120
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    I've changed the topic to something our team understands and have opened a ticket.

  6. #6
    Sencha Premium Member
    Join Date
    Apr 2011
    Posts
    52
    Vote Rating
    1
    rh_it is on a distinguished road

      0  

    Default


    Oh brilliant Aaron, thanks a lot! It would be very useful for a developer indent variables after equal signs.

Thread Participants: 1

Tags for this Thread