1. #1
    Sencha User
    Join Date
    Sep 2012
    Posts
    14
    Vote Rating
    0
    abrizvi is on a distinguished road

      0  

    Default Hello World Example

    Hello World Example


    Hi All,

    I've been trying to get Sencha Touch 2 on my android tablet. I'm fairly new to ST2. So far, I created an app using 'sencha generate app MyApp path/to/my/App'. I'm assuming I need to do a native build so I ran the command 'sencha app build native'. When I run the command, I get a "Content is not allowed in trailing section" org.xml.sax.SAXParseException in my build.xml file in the android sdk directory. Also, I don't see any files being populated in the folder I specified in the output path. Any help would be appreciated. thanks

    Windows 7/ 64-bit/ Sencha2.0.1.1
    Bruce

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    8,873
    Vote Rating
    439
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      0  

    Default


    Moved to ST2 forums.

    Scott.

  3. #3
    jay@moduscreate.com's Avatar
    Join Date
    Mar 2007
    Location
    Frederick MD, NYC, DC
    Posts
    16,353
    Vote Rating
    77
    jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all jay@moduscreate.com is a name known to all

      0  

    Default


    Should this be moved to the Cmd forums instead?

  4. #4
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    8,873
    Vote Rating
    439
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      0  

    Default


    You are correct .. Hopefully the OP does not get lost

    Scott.

  5. #5
    Sencha User
    Join Date
    Sep 2012
    Posts
    14
    Vote Rating
    0
    abrizvi is on a distinguished road

      0  

    Default


    Thanks guys,

    I've tried all the tutorials and documents online but no luck. I'm still looking into it. thanks in advance.


    Bruce

  6. #6
    Sencha User
    Join Date
    Sep 2012
    Posts
    14
    Vote Rating
    0
    abrizvi is on a distinguished road

      0  

    Default Update

    Update


    Hi,

    Update. I still can't successfully build the package. However, I did manage to view the semi-build before it gave me the error: "filename or extension is too long". I'm trying to deploy a generic code using sencha on my tablet without using a web server. thanks

  7. #7
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Posts
    1,295
    Vote Rating
    121
    dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all

      0  

    Default


    If you can upgrade to Sencha Touch 2.1 Beta 3, you can use the new packager in Sencha Cmd V3 which has a lot of bug fixes.

    If you need to stick with Sencha Touch 2.0.x, you'll need to use Sencha SDK Tools V2.

    It looks like you are using Sencha Touch 2.0.1.1, but what about the version of the tooling?
    Don Griffin
    Ext JS Development Team Lead

    Check the docs. Learn how to (properly) report a framework issue and a Sencha Cmd issue

    "Use the source, Luke!"

  8. #8
    Sencha User
    Join Date
    Sep 2012
    Posts
    14
    Vote Rating
    0
    abrizvi is on a distinguished road

      0  

    Default


    Hi,

    I'm using Sencha Touch 2.0.1.1 and SDK Tool 2.0.0-Beta3. I don't see any version listed. Should I uninstall and use version 2.1 Beta 3? Thanks

  9. #9
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Posts
    1,295
    Vote Rating
    121
    dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all dongryphon is a name known to all

      0  

    Default


    Quote Originally Posted by abrizvi View Post
    Hi,

    I'm using Sencha Touch 2.0.1.1 and SDK Tool 2.0.0-Beta3. I don't see any version listed. Should I uninstall and use version 2.1 Beta 3? Thanks
    That mostly depends on where you are in your project. If you can, upgrading to Sencha Touch 2.1 beta 3 and Cmd V3 should bring you a lot of bug fixes and such, but you will also have some beta issues to deal with.
    Don Griffin
    Ext JS Development Team Lead

    Check the docs. Learn how to (properly) report a framework issue and a Sencha Cmd issue

    "Use the source, Luke!"