1. #1
    Sencha User
    Join Date
    Nov 2012
    Posts
    6
    Vote Rating
    -1
    digitalworkroom is an unknown quantity at this point

      0  

    Default Unanswered: WARN] The current working directory (/Applications/MAMP/htdocs/sencha-touch-2.1.0...

    Unanswered: WARN] The current working directory (/Applications/MAMP/htdocs/sencha-touch-2.1.0...


    Hi Guys,

    have been stucked on this almost the whole day now.

    I downloaded the latest SDK - sencha-touch-2.1.0-commercial, put it in my MAMP/htdocs/ folder.

    Then downloaded the SDK Tools - SenchaSDKTools-2.0.0-beta3, installed under Applications/.

    Following the Getting Started docs, I cd into my sencha-touch-2.1.0-commercial directory under MAMP/htdocs and typed in generate .....


    ..encha-touch-2.1.0-commercial Terenze$ sencha
    [WARN] The current working directory (/Applications/MAMP/htdocs/sencha-touch-2.1.0-commercial) is not a recognized Sencha SDK or application folder. Running in backwards compatible mode.

    Sencha Command v2.0.0 Beta 3
    Copyright (c) 2012 Sencha Inc.

    usage: sencha COMMAND [ARGS]

    The available commands are:
    build build a JSB project
    create bootstrapdata generate boostrap data
    create jsb generate a minimal JSB project for an app
    create locale generate a template locale file from source
    create manifest generate classes manifest
    package package your Touch web app into a native bundle
    slice theme slice a custom theme's images for IE

    See 'sencha help COMMAND' for more information on a specific command.
    Then I get this error no matter what I try (adding .senchasdk) etc. Please help as I really need to get this moving!!

    Appreciate any help truly.

    Thanks.

  2. #2
    Sencha Premium Member
    Join Date
    Oct 2012
    Posts
    46
    Answers
    2
    Vote Rating
    0
    heath.hansell is on a distinguished road

      0  

    Default


    outdated version of sencha cmd?
    mine is Sencha Cmd v3.0.0.250

  3. #3
    Sencha User
    Join Date
    Nov 2012
    Posts
    6
    Vote Rating
    -1
    digitalworkroom is an unknown quantity at this point

      -1  

    Default


    But I downloaded the SDK Tools at:
    http://www.sencha.com/products/sdk-tools/download

    Please guide as I do need to get this up and running.

    Thanks.

  4. #4
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    37,047
    Answers
    3493
    Vote Rating
    850
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      -1  

    Default


    Please stop posting the same thing over and over. If it's put under moderation what makes you think if you keep posting it will stop moderating you?
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  5. #5
    Sencha User
    Join Date
    Nov 2012
    Posts
    6
    Vote Rating
    -1
    digitalworkroom is an unknown quantity at this point

      0  

    Default


    Sorry, just being desperate. There are no where on the site that states how this issue can be troubleshooted and it seems to be a very common problem?

  6. #6
    Sencha User
    Join Date
    Nov 2012
    Posts
    6
    Vote Rating
    -1
    digitalworkroom is an unknown quantity at this point

      0  

    Default


    Running the generate just throws this error:

    $ sencha generate app GS ../GS
    [ERROR] The current working directory (/Applications/MAMP/htdocs/sencha-touch-2.1.0-gpl/docs) is not a valid SDK directory. Please 'cd' into a SDK directory before executing this command.

    Would be good if there is some installation troubleshooting guide at Getting Started docs.

    Thanks.

  7. #7
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    37,047
    Answers
    3493
    Vote Rating
    850
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    For Touch 2.1.0 you have to use Sencha Cmd which looks like you don't have installed.
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  8. #8
    Sencha User
    Join Date
    Nov 2012
    Posts
    6
    Vote Rating
    -1
    digitalworkroom is an unknown quantity at this point

      0  

    Default


    I did but it doesnt work.

    Anyway found the reason - you have to restart your mac. Would be good to add this onto the Getting Started guide - I wasted a lot of time on this.

    Thanks.

  9. #9
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    37,047
    Answers
    3493
    Vote Rating
    850
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    I've never had to restart my mac. Did you open a new Terminal window after installing Cmd so the new path would be used?
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  10. #10
    Ext JS Premium Member itlogo's Avatar
    Join Date
    Mar 2008
    Posts
    37
    Vote Rating
    1
    itlogo is on a distinguished road

      0  

    Default Having the same problem

    Having the same problem


    I'm having the same issue. I downloaded the 2.1.0 SDK from http://www.sencha.com/products/touch/download/, then the tools from http://www.sencha.com/products/sdk-t...0.0-beta-3/mac (this is linked from http://www.sencha.com/products/sdk-tools/download for Mac). The tools installed and updated by .bash_profile and .bashrc with

    ...

    export PATH=/Applications/SenchaSDKTools-2.0.0-beta3:$PATH

    export SENCHA_SDK_TOOLS_2_0_0_BETA3="/Applications/SenchaSDKTools-2.0.0-beta3"

    I restarted Terminal.app so that the sencha command is in my PATH, and getting the exact same errors as digitalworkroom. I even tried restarting the computer but same problem.

    Is the link for Mac tools pointing to an incorrect version for the downloaded Touch SDK?