Hi, still new with sencha touch/architect so I may be doing something wrong. I recently installed Architect 2.1 using touch 2.1 to create a sample/test app. The issue is that it seems to run fine if launched from safari by entering the url but if I bookmark it to the homescreen and launch it from there, all I see is a white screen. I've tried to pinpoint when it fails and it seems that if I add a form field (ie email field) to a container, it just shows the white screen when launched from the homescreen bookmark but seems to display just fine from the browser. Is there something special I have to do with form fields for it to launch properly from the homescreen? It seems to work fine if I just have a basic label and no form fields.

Here's a basic example that fails for me launching from the home screen: Added a container named MyContainer with an emailfield and a label using Architect's ui drag and drop- no extra code or functions. Saved it and it previews fine from the ios browser - bookmark it and launch and all I see is a white screen.

code in app.js:
Code:
Ext.Loader.setConfig({
    enabled: true
});


Ext.application({
    views: [
        'MyContainer'
    ],
    name: 'MyApp',


    launch: function() {


        Ext.create('MyApp.view.MyContainer', {fullscreen: true});
    }


});


and code in MyContainer.js


Ext.define('MyApp.view.MyContainer', {
    extend: 'Ext.Container',


    config: {
        items: [
            {
                xtype: 'emailfield',
                id: 'myemailfield',
                itemId: 'myemailfield',
                label: 'Email',
                placeHolder: 'email@example.com'
            },
            {
                xtype: 'label',
                html: 'test'
            }
        ]
    }


});