1. #1
    Sencha User
    Join Date
    Sep 2011
    Posts
    26
    Answers
    1
    Vote Rating
    1
    matdar is on a distinguished road

      0  

    Default Unanswered: Native Build for IOS fails using Cmd 3.0.0.250 with stbuild_template malformed object

    Unanswered: Native Build for IOS fails using Cmd 3.0.0.250 with stbuild_template malformed object


    I've upgraded to 2.1 and am using the cmd to build a native IOS app but the build fails with:

    Code:
    sencha package build -p ./packager.json 
    Sencha Cmd v3.0.0.250
    [ERR]        
    codesign_allocate: object: /webroot/[abc]/sencha_2.1/converted/build///[myapp].app/stbuild_template malformed object (unknown load command 34)
    ../build///[myapp].app: object file format invalid or unsuitable
    The application was successfully packaged
    Failed to execute system command while signing application with error 256
    Failed to package application
    
    
    [ERR]        stbuild exited with non-zero code : 6
    If I set the platform to iOSSimulator the build works and runs the simulator ok.

    I'm running on OSX.

    Here's my package.json:

    Code:
    {
        
        "applicationName":"[myapp]",
        "applicationId":"com.[my company].[myapp]",
        "versionString":"1.2.0",
             "provisionProfile": "/[my path]/provisioning_profiles/[myapp].mobileprovision",
            "minOSVersion":"5.0",
            "bundleSeedId":"[my bundle seed]",
    "icon": {
                    "57": "resources/icons/Icon.png",
                    "72": "resources/icons/Icon~ipad.png",
                    "114": "resources/icons/Icon@2x.png",
                    "144": "resources/icons/Icon~ipad@2x.png"
                    },
        "inputPath":"./",
        "outputPath":"../build/",
        "configuration":"Release",
        "platform":"iOS",
        "deviceType":"Universal",
        "certificatePath":"../../../certificate/Certificates.p12",
        "certificateAlias":"iPhone Distribution: [my company]",
        "sdkPath":"/development/android-sdk-macosx",
        "androidAPILevel":"15",
        "orientations": [
            "portrait",
            "portraitUpsideDown"
        ]
          
    }
    Has anyone seen this or got any suggestions?

    Thanks
    Matt

  2. #2
    Sencha User
    Join Date
    Jul 2010
    Posts
    1
    Vote Rating
    2
    danjar is on a distinguished road

      2  

    Default


    I had this exact same issue and I resolved it by following the instructions from here:
    http://reaver.angka.net/questions/12...e-in-xcode-4-5

    It turns out upgrading XCode from App Store does NOT automatically upgrade everything.
    Go to Preferences / Downloads and make sure the latest Command Line Tools are installed.

  3. #3
    Sencha User
    Join Date
    Sep 2007
    Posts
    134
    Vote Rating
    0
    rballman is on a distinguished road

      0  

    Default


    is Xcode needed when you are just using the Sencha CMD via Terminal?

    I am getting this error too

  4. #4
    Sencha User
    Join Date
    Nov 2011
    Posts
    3
    Vote Rating
    0
    AndyDavo is on a distinguished road

      0  

    Default


    This also solved the issue for me

  5. #5
    Sencha User
    Join Date
    Jan 2013
    Posts
    21
    Vote Rating
    1
    brian.scott@talgov.com is an unknown quantity at this point

      0  

    Default Thank you, Thank you, Thank you!

    Thank you, Thank you, Thank you!


    +1000 karma for danjar!