1. #1
    Sencha User
    Join Date
    Dec 2012
    Posts
    2
    Vote Rating
    0
    santoshpatil is on a distinguished road

      0  

    Default Unanswered: Not a vaild SDK deirctory

    Unanswered: Not a vaild SDK deirctory


    Hi,
    I have installed sencha-touch-2.0.0-gpl and SenchaSDKTools-2.0.0-beta3. but when i try to run any command through cmd, it shows error "the current working directory "C:\Program Files\apache-tomcat-7.0.34-windows-x86\apache-tomcat-7.0.34\webapps\sencha-touch-2.0.0-gpl" is not a valid SDK directory. please 'cd' into a SDK directory before executing this command"

    I installed sencha-touch-2.0.0-gpl in C:\Program Files\apache-tomcat-7.0.34-windows-x86\apache-tomcat-7.0.34\webapps folder and SenchaSDKTools-2.0.0-beta3 in C:\Program Files folder.

    Please help me as i am new to sencha

    Thanks

    Santosh

  2. #2
    Sencha User
    Join Date
    Nov 2011
    Location
    England
    Posts
    135
    Vote Rating
    7
    Answers
    11
    george.m is on a distinguished road

      0  

    Default


    do it from the sdk tools directory instead

  3. #3
    Sencha User
    Join Date
    Dec 2012
    Posts
    2
    Vote Rating
    0
    santoshpatil is on a distinguished road

      0  

    Default


    I tried from SDK Tools directory also, but in vain. It s showing same error

  4. #4
    Sencha User
    Join Date
    Dec 2012
    Posts
    6
    Vote Rating
    0
    ilovefood is on a distinguished road

      0  

    Default


    try downloading and installing Sencha Cmd instead of Sencha SDK, I had the same issue before installing the former (have installed both now, just in case)

    http://www.sencha.com/products/sencha-cmd/download

  5. #5
    Sencha User
    Join Date
    Oct 2012
    Posts
    17
    Vote Rating
    0
    Answers
    1
    transwebsolutions is on a distinguished road

      0  

    Default


    i would remove JDK/JRE if have installed any and Sencha SDK tools.

    Install only the JDK, it contains JRE. Then download Ruby, SASS and COMPASS. If you are on MAC, then download XCODE from the appstore. Finally download and install xcode command line tools.