Hybrid View

  1. #1
    Sencha User
    Join Date
    Dec 2012
    Posts
    38
    Vote Rating
    3
    panbayi is on a distinguished road

      0  

    Default Problem in parsing XML packaged with SOAP Envelope

    Problem in parsing XML packaged with SOAP Envelope


    I'm using ExtJS 4.1.1 ,and I quoted and override the Soap Proxy in 4.1.3 .Now I can send Soap request to and receive response from my SOAP Web Service, but I cannot parse the XML received from the service. My XML is extremely like the XML in the example on this site http://docs.sencha.com/ext-js/4-1/#!/guide/soap. But it throws an error : Uncaught Ext.DomQuery.compile(): Error parsing selector. Parsing failed at "|Body" .Can anyone help me please?
    Last edited by panbayi; 24 Dec 2012 at 5:57 PM. Reason: change

  2. #2
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    37,642
    Vote Rating
    899
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    What is the xml looking like?
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  3. #3
    Sencha User
    Join Date
    Dec 2012
    Posts
    38
    Vote Rating
    3
    panbayi is on a distinguished road

      0  

    Default


    Thank you for your concern.It raises the error because the XTemplate.js in 4.1.1 is different from 4.1.3, so I just need to copy it.

    Thank you again for you reply!

Thread Participants: 1

Tags for this Thread