Hybrid View

  1. #1
    Sencha User
    Join Date
    Dec 2012
    Posts
    2
    Vote Rating
    0
    jaymorgan is on a distinguished road

      0  

    Default Unanswered: Can't get it to work from the install

    Unanswered: Can't get it to work from the install


    I have run "SenchaSDKTools-2.0.0-beta3-osx" and downloaded the SDK folders "sencha-touch-2.1.0-gpl"

    I have a folder in my root folder named "sencha" which contains the tools app and the sdk folder.

    I cd into the folder in terminal and run the "sencha" command and I get this error.
    "[WARN] The current working directory (/Applications/MAMP/htdocs/sencha/sencha-touch-210) is not a recognized Sencha SDK or application folder. Running in backwards compatible mode."

    Can someone help with this? I can't find any real info that I can comprehend. This is so frustrating.

  2. #2
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    36,754
    Answers
    3462
    Vote Rating
    828
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    For Sencha Touch 2.1.0+ you should be using Sencha Cmd 3 as said in the blog: http://www.sencha.com/blog/introduci...-2-1-and-more/
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Forum Manager
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  3. #3
    Sencha User
    Join Date
    Dec 2012
    Posts
    2
    Vote Rating
    0
    jaymorgan is on a distinguished road

      0  

    Default


    Thanks Mitchell, the Getting Started Guide should be updated to reflect this. I was completely led astray by the documentation, not good.

    I tried installing it and it seems to want to install the files in Users/jaymorgan/bin , that doesn't seem right. Does it need to go into the usr/bin directory?

  4. #4
    Sencha User
    Join Date
    Apr 2013
    Posts
    2
    Vote Rating
    0
    lorkel is on a distinguished road

      0  

    Default


    I'm left in the same spot as jaymorgan - it's asking if I want to install in Users/lorkel/bin, but I'm using MAMP on a Mac so I thought it would go in Applications/MAMP/htdocs.

    At this point in terminal I can run:
    sencha generate app GS ../GS (note: Getting Started still lists the command as sencha app create MyApp ../MyApp which appears to be depreciated)

    And it seems to run until it hits a "Unable to locate 'framework.dir' property from sencha.cfg // Please ensure this command was executed from a valid framework"

    Am I using the wrong SDK in combination with the cmd? Please point me in the right direction - and update the documentation!

  5. #5
    Sencha User
    Join Date
    Jan 2012
    Location
    London, UK
    Posts
    498
    Answers
    25
    Vote Rating
    51
    shepsii has a spectacular aura about shepsii has a spectacular aura about shepsii has a spectacular aura about

      0  

    Default


    Is this of any help for you? http://senchatouchdev.com/wordpress/2013/03/04/sencha-touch-2-1-1-getting-started/

    Y
    ou need to make sure you execute the generate app command from the touch-2.1.1 directory you downloaded. You need sencha cmd 3+ for 2.1.1 and sencha cmd 3.1+ for 2.2. Note sencha cmd != sencha sdk tools. Those are the two most common gotchas!

    I agree the getting started docs could do with an update for sure. Scares me to think how many potential developers for sencha touch might have been scared away by these issues.
    I blog about Sencha Touch at www.senchatouchdev.com

  6. #6
    Sencha User
    Join Date
    Apr 2013
    Posts
    2
    Vote Rating
    0
    lorkel is on a distinguished road

      0  

    Default


    Thank you for the reply shepsii! I found the answer in the documentation here:

    http://docs.sencha.com/touch/2-1/#/guide/command

    The link you posted sounds correct too, although it doesn't include needing a Java Run-Time Environment or Compass, which the documentation cites as requirements for Cmd to run. Even with the step by step instructions there was still a missing piece, restarting Terminal after installing Cmd so the "sencha" command will run. Super frustrating!

    Anyway thank you for your reply!

Turkiyenin en sevilen filmlerinin yer aldigi xnxx internet sitemiz olan ve porn sex tarzi bir site olan mobil porno izle sitemiz gercekten dillere destan bir durumda herkesin sevdigi bir site olarak tarihe gececege benziyor. Sitenin en belirgin ozelliklerinden birisi de Turkiyede gercekten kaliteli ve muntazam, duzenli porno izle siteleri olmamasidir. Bu yuzden iste. Ayrica en net goruntu kalitesine sahip adresinde yayinlanmaktadir. Mesela diğer sitelerimizden bahsedecek olursak, en iyi hd porno video arşivine sahip bir siteyiz. "The Best anal porn videos and slut anus, big asses movies set..." hd porno faketaxi