1. #1
    Sencha User
    Join Date
    Jan 2013
    Posts
    2
    Vote Rating
    0
    wild is on a distinguished road

      0  

    Default Unanswered: Sencha isn't launching Simulators

    Unanswered: Sencha isn't launching Simulators


    Hi everybody!

    I've just installed Sencha CMD and Sencha Touch Latest versions and try to make a new app so after "sencha generate app example ../example" I could see the results on my browse, but when I tried "sencha app build native" to se how it works on the simulator nothing happens. No errors, no messages and no Launch. I'm using Mac OS and I've already develop for iOS.

    Somebody knows what should I do?

    Tks!

  2. #2
    Sencha Premium Member
    Join Date
    Sep 2012
    Location
    The Netherlands
    Posts
    79
    Vote Rating
    4
    Answers
    7
    zwikske is on a distinguished road

      0  

    Default


    I'm not sure if you did this as you didn't mention it in your post. You need to make sure the settings in your 'packager.json' match with the setting you like. If you want to build for iOS you need to set the iOS specific parameters such as provisioning ID.

    More information can be found here: http://docs.sencha.com/touch/2-1/#!/...tive_packaging

    Hope this helps to get you going!

  3. #3
    Sencha User
    Join Date
    Jan 2013
    Posts
    2
    Vote Rating
    0
    wild is on a distinguished road

      0  

    Default


    Thanks for the answer!

    I've already adjusted the settings of package.json as usual. I think the problem is this new Sencha CMD version. The old version worked fine.

    Well, after research a lot without any good results, I figured out about the parameter -r and with this finally worked, so to launch the iOSsimulator to see the build, I have to write:

    sencha app build -r native

    This worked fine only when my parameters is focusing in iOS, if I adjust to Android the build is completed but the simulator doesn't launch.

    Thank you!

Thread Participants: 1

Tags for this Thread