1. #1
    Sencha User
    Join Date
    May 2012
    Location
    rome
    Posts
    68
    Vote Rating
    0
    Answers
    3
    alexdran is on a distinguished road

      0  

    Default Answered: sencha cmd 3.0.0.250 build problems

    Answered: sencha cmd 3.0.0.250 build problems


    Hello all,
    I have migrate do sencha cmd3, it seems more performant and final apps more responsive

    I have however some problems after build

    1. minimizing css remove custom created css (i.e. for new icons) and also loader waiter is no longer animated

    2. including my models/stores/controllers; after build (sencha app build package) the final output is not working. With the following error on chrome console


    any suggestion ?
    thank you in advance for your help in this

    Alex!!!

  2. You need to include 'Ext.data.identifier.Uuid' into your requires statement :

    requires: ['Ext.data.identifier.Uuid', 'Ext.data.proxy.LocalStorage']

  3. #2
    Sencha User
    Join Date
    May 2012
    Location
    rome
    Posts
    68
    Vote Rating
    0
    Answers
    3
    alexdran is on a distinguished road

      0  

    Default


    After some investigation I discovered:
    it seems I get this error only if I include identifier in my Model Class

    Code:
    Ext.define('SC.model.config.uuser', {
        extend: 'Ext.data.Model',
        requires: 'Ext.data.proxy.LocalStorage',
    
    
        config: {
            identifier : 'uuid',
    
    
            fields: [
                {name: 'iid', type: 'int'},
                {name: 'uid', type: 'string'}
            ]
        }
    });
    the build is working with that line commented

    Code:
    Ext.define('SC.model.config.uuser', {
        extend: 'Ext.data.Model',
        requires: 'Ext.data.proxy.LocalStorage',
    
    
        config: {
            //identifier : 'uuid',
    
    
            fields: [
                {name: 'iid', type: 'int'},
                {name: 'uid', type: 'string'}
            ]
        }
    });
    does anyone has suggestion for this behavior?
    thank you again for any info!

    Alex

  4. #3
    Sencha User
    Join Date
    Mar 2010
    Posts
    1
    Vote Rating
    0
    Answers
    1
    johan__r is on a distinguished road

      0  

    Default


    You need to include 'Ext.data.identifier.Uuid' into your requires statement :

    requires: ['Ext.data.identifier.Uuid', 'Ext.data.proxy.LocalStorage']

  5. #4
    Sencha User
    Join Date
    May 2012
    Location
    rome
    Posts
    68
    Vote Rating
    0
    Answers
    3
    alexdran is on a distinguished road

      0  

    Default


    tried and successfully built!
    thank you

    alex

Thread Participants: 1

Tags for this Thread