1. #1
    Sencha User
    Join Date
    Apr 2012
    Posts
    82
    Answers
    5
    Vote Rating
    1
    markevans is on a distinguished road

      0  

    Default Answered: Blank White Screen in iOS Simulator, but works fine on the actual device (iPhone)?

    Answered: Blank White Screen in iOS Simulator, but works fine on the actual device (iPhone)?


    Tried searching around. Not a lot of experience in XCode. Anyway, the odd thing is that the native package (Sencha) for my app (ST2.1) works fine when I load it on my iPhone device, but I cannot get it to run on my Simulator. I changed the platform in the build config file and generated a separate file (it created an app and an entitlements file).

    I dragged them into a new project in XCode and ran the 6.0 simulator. It says the build is fine and the simulator comes up with a blank white screen. If I click the home button, the icon is also blank white.

    I tried resetting the "Contents and Settings" as someone suggested, but no luck.

    The message in the output window is:
    2013-01-09 23:01:57.352 Tally[6730:c07] Application windows are expected to have a root view controller at the end of application launch

  2. Got it running. I used "sencha package run <configfile>" instead of "sencha package build <configfile>" and this built the app and then brought up the simulator. Still had a problem the first time when process failed with error 1, but doing "iOS Simulator > Reset Content & Settings" while the simulator was running cleared it out and the next run worked.

    This should work fine - I assume some other config for the XCode project must be in place to run from within that app.

  3. #2
    Sencha User
    Join Date
    Apr 2012
    Posts
    82
    Answers
    5
    Vote Rating
    1
    markevans is on a distinguished road

      0  

    Default For iOSSimulator platform, use "run" instead of "build"

    For iOSSimulator platform, use "run" instead of "build"


    Got it running. I used "sencha package run <configfile>" instead of "sencha package build <configfile>" and this built the app and then brought up the simulator. Still had a problem the first time when process failed with error 1, but doing "iOS Simulator > Reset Content & Settings" while the simulator was running cleared it out and the next run worked.

    This should work fine - I assume some other config for the XCode project must be in place to run from within that app.

Turkiyenin en sevilen filmlerinin yer aldigi xnxx internet sitemiz olan ve porn sex tarzi bir site olan mobil porno izle sitemiz gercekten dillere destan bir durumda herkesin sevdigi bir site olarak tarihe gececege benziyor. Sitenin en belirgin ozelliklerinden birisi de Turkiyede gercekten kaliteli ve muntazam, duzenli porno izle siteleri olmamasidir. Bu yuzden iste. Ayrica en net goruntu kalitesine sahip adresinde yayinlanmaktadir. Mesela diğer sitelerimizden bahsedecek olursak, en iyi hd porno video arşivine sahip bir siteyiz. "The Best anal porn videos and slut anus, big asses movies set..." hd porno faketaxi