You found a bug! We've classified it as DSGNR-3604 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha Premium Member intellix's Avatar
    Join Date
    Mar 2012
    Location
    UK + Malta
    Posts
    263
    Vote Rating
    18
    intellix will become famous soon enough

      0  

    Default scrollable: null - added in 2.1.1 and not possible to do in SA

    scrollable: null - added in 2.1.1 and not possible to do in SA


    as title says, it's not possible to set scrollable to null as 2.1.1 is now warning me about.

  2. #2
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,304
    Vote Rating
    125
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    In the initialize method of the component invoke this.setScrollable(null);

    We have future plans to make it easier for users to set null or undefined which is not currently possible from the config grid.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  3. #3
    Sencha Premium Member intellix's Avatar
    Join Date
    Mar 2012
    Location
    UK + Malta
    Posts
    263
    Vote Rating
    18
    intellix will become famous soon enough

      0  

    Default


    Hmm, doesn't seem to work.

    Setting scrollable: null in the config works but this.setScrollable(null); within initializer event doesn't. If I look at the inner it has .x-scroll-scroller which is setting it to absolute positioning and adds the 3d webkit transform.

    Element with scrollable: null when I getScrollable says undefined but the other has the scrollable object there. Seems the setScrollable doesn't work within initializer

    I'm doing this on a DataView btw

  4. #4
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,304
    Vote Rating
    125
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Hrm this should work. Will check in with the touch team to see if there is a potential bug here.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  5. #5
    Sencha Premium Member intellix's Avatar
    Join Date
    Mar 2012
    Location
    UK + Malta
    Posts
    263
    Vote Rating
    18
    intellix will become famous soon enough

      0  

    Default


    The ability to specify null wasn't added in SA 2.2

    Still having to do it on initialize method and that doesn't seem to work. (I could try nightly build but something else always dies when I try new versions).

    Did you ever get a reply from the touch team, cause they didn't reply on another thread :P

    Always living on the edge of ST releases. 2.1.0 gives WSOD on iOS homescreen. 2.1.1 makes me do scrollable(null) and is not possible in architect more than a month after being changed!

  6. #6
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,304
    Vote Rating
    125
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Quote Originally Posted by intellix View Post
    Still having to do it on initialize method and that doesn't seem to work. (I could try nightly build but something else always dies when I try new versions).

    Did you ever get a reply from the touch team, cause they didn't reply on another thread :P
    No. Will try to see what is up here.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  7. #7
    Touch Premium Member BostonMerlin's Avatar
    Join Date
    Aug 2010
    Location
    Boston
    Posts
    522
    Vote Rating
    41
    BostonMerlin has a spectacular aura about BostonMerlin has a spectacular aura about BostonMerlin has a spectacular aura about

      0  

    Default


    I'm hitting the same problem. I'm trying to show multiple dataviews (not lists) one after the other on a vertically scrolling container.

    I"m told
    we need to set null on each dataviews scrollable config. Setting null on the config does not work in the latest architect beta. If I change the scrollable config type to object then set null in the object editor, architect reverts back to false when you exit.

    Since that doesn't work, we're told to set null on the init of the container but like the OP said, that doesnt work either. ST ignores that setting at runtime.

    Options?

    Thanks,
    John

  8. #8
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,304
    Vote Rating
    125
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Setting it on init of the container should work.

    We can also add a null configuration into the scrollable dropdown.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  9. #9
    Sencha - Architect Dev Team jjohnston's Avatar
    Join Date
    Sep 2010
    Posts
    556
    Vote Rating
    19
    jjohnston will become famous soon enough jjohnston will become famous soon enough

      0  

    Default


    I'm having trouble finding information about scrollable:null and what it means. How is it different than scrollable:false? Can you point me to where in the documentation this is discussed?
    Jason Johnston
    @lojjic
    Sencha Architect Development Team

  10. #10
    Touch Premium Member BostonMerlin's Avatar
    Join Date
    Aug 2010
    Location
    Boston
    Posts
    522
    Vote Rating
    41
    BostonMerlin has a spectacular aura about BostonMerlin has a spectacular aura about BostonMerlin has a spectacular aura about

      0  

    Default


    Mitchell pointed us in the direction of using 'null' on a dataview (not list) scrollable config as false doesnt work. I detailed the problem of setting null in SA as an object type in my thread response up top.

    I"m told we need to set null on each dataviews scrollable config. Setting null on the config does not work in the latest architect beta. If I change the scrollable config type to object then set null in the object editor, architect reverts back to false when you exit.

    Thanks,
    John