1. #1
    Sencha User
    Join Date
    Feb 2013
    Posts
    3
    Vote Rating
    0
    skmp is on a distinguished road

      0  

    Default Unanswered: scrollable: false in Ext.form.Panel and migrating from 2.1.0rc2 to 2.1.1

    Unanswered: scrollable: false in Ext.form.Panel and migrating from 2.1.0rc2 to 2.1.1


    I'm migrating a project from 2.1.0rc2.

    In a login form, scrollable: false is set and it used to work fine.

    On 2.1.1 the items on the form are not visible, and in the js console a warning appears "[WARN][Ext.form.Panel#applyScrollable] This container is set to scrollable: false but has no specified height. You may need to set the container to scrollable: null or provide a height. ".

    Setting it to scrollable: null works, but I don't see any reference about that on the docs (or any reference to scrolling and height).

    The form is in a panel with hbox layout, which is in a fullscreen container.

    Any ideas why scrolling: null is required and what it actually does ?

  2. #2
    Sencha User
    Join Date
    Oct 2012
    Location
    Poland
    Posts
    70
    Answers
    4
    Vote Rating
    5
    szimek is on a distinguished road

      0  

    Default


    Had exactly the same problem after updating to 2.1.1. The thing is that the warning message suggests working solution, but API docs don't mention `null` value at all - it says that the only allowed values are boolean, string or object.

Thread Participants: 1