1. #11
    Sencha Premium Member
    Join Date
    Mar 2013
    Posts
    6
    Vote Rating
    0
    gerd_uwe_mueller is on a distinguished road

      0  

    Default


    There is definitely a problem with RubyInstaller 2.0.0, sencha cmd v3.1.0256 and compass 0.12.2., ext-4.2.0.663

    I had the same problem (failure after 'executing compass using system installed ruby runtime') when doing sencha package build.

    Downgraded to Ruby 1.9.3, everything works. (Mix of 32 bit and 64 bit versions was my first idea, before reading this thread, I use the 32 bit versions on a 64 bit Windows 7 machine)

    Gerd

  2. #12
    Sencha User swarnendude's Avatar
    Join Date
    Jul 2009
    Location
    Kolkata, India
    Posts
    117
    Vote Rating
    1
    swarnendude is on a distinguished road

      0  

    Default


    Quote Originally Posted by gerd_uwe_mueller View Post
    Downgraded to Ruby 1.9.3, everything works. (Mix of 32 bit and 64 bit versions was my first idea, before reading this thread, I use the 32 bit versions on a 64 bit Windows 7 machine)
    I am also getting the same issue while creating production build for a Sencha Touch app 2.2b2 SDK. Here are the versions I am using:

    Ruby v1.9.3p327
    CMD v3.1.0.256
    Sencha Touch SDK v2.2.0-b2
    Windows 7, 32 bit


    So, is it working for you with a later version of Ruby? Somehow I am no way able to create a production build with Sencha Touch 2.2 . I have tried with 2-3 CMD versions and ST 2.2 alpha, beta 1 and beta 2.

    Any help?
    Swarnendu
    Co-founder & Lead Architect @ Innofied

    ------------------
    I blog at http://www.swarnendude.com

  3. #13
    Sencha Premium Member
    Join Date
    Jan 2013
    Posts
    42
    Vote Rating
    4
    Dev@QLP is on a distinguished road

      0  

    Default


    I don't really use ST so I'm not sure but perhaps ST 2.2 isn't supported yet because it is still in beta?

  4. #14
    Sencha Premium Member
    Join Date
    Mar 2013
    Posts
    6
    Vote Rating
    0
    gerd_uwe_mueller is on a distinguished road

      0  

    Default


    Hello,

    Sorry, Environment was ext-4.2.0.663, not Sencha Touch.

    Regards,
    Gerd

  5. #15
    Sencha User
    Join Date
    Feb 2013
    Posts
    2
    Vote Rating
    0
    johnnyd is on a distinguished road

      0  

    Default


    Installed Sencha Cmd 3.1 (from 3.0). Same pb with ruby.
    Just downgraded to Ruby 1.9.3-p392. Problem gone away. Thanks
    (Windows 7SP1 x64.)

  6. #16
    Sencha User nbabinski's Avatar
    Join Date
    Apr 2011
    Location
    Ukraine, Kyiv
    Posts
    21
    Vote Rating
    2
    nbabinski is on a distinguished road

      0  

    Default


    Downgrading Ruby to 1.9.3-p392 really solves the problem using:
    Tool: 3.1.0.256
    ExtJS: 4.2.0.663

    @hschaefer123 @Arjen de Kivet thanks for sharing information

  7. #17
    Touch Premium Member
    Join Date
    Jun 2008
    Location
    Germany, Dortmund
    Posts
    249
    Vote Rating
    12
    hschaefer123 will become famous soon enough

      0  

    Default


    But maybe that is only one part of the medal.

    Currently i am trying to build a production release with a custom theme.
    As a result, generating theme inside package dir is working
    but the production release generates an empty AppName.css resource.

    Also the generated AppAll.js does not include all needed libs.

    I opened a forum post but currently got no response.

    I think the first call to sencha app build was successfully, but then after CMD replaced Bootstrap.css with path to production release (maybe cmd tries to include builded css before it is builded ?!?).

    Hopefully i will get a working build around the next days.

    Cheers Holger

  8. #18
    Sencha User mysticav's Avatar
    Join Date
    Mar 2007
    Location
    Mexico
    Posts
    474
    Vote Rating
    5
    mysticav is on a distinguished road

      0  

    Default


    I was able to fix this problem deleting the build/ directory generated byExtJS.
    Using Ext with cachefly
    Working on LAMPExt

  9. #19
    Sencha User
    Join Date
    Feb 2013
    Posts
    16
    Vote Rating
    0
    SapphireSky is on a distinguished road

      0  

    Default Downgrading to version 1.9.3 doesn't help

    Downgrading to version 1.9.3 doesn't help


    So when i first got this error, I was running 1.9.3p385 using CMD 3.1.2.342. It was working fine a few days ago, but now it gives that error. The only thing that might have changed, is I updated Java from 7.17 to 7.21.

    I did notice that this version of Java came out AFTER most of the posts in this thread. Could that be the cause?

    EDIT: nevermind, there was a 'syntax error' in my sass and fixing it made build. (i put syntax error in quotes because it red, green blue etc are valid colors but 'orange' is apparently not according to compiler)
    Last edited by SapphireSky; 5 Jun 2013 at 10:39 AM. Reason: new information

  10. #20
    Ext GWT Premium Member
    Join Date
    Oct 2009
    Posts
    131
    Vote Rating
    5
    zlevardy is on a distinguished road

      0  

    Default ruby 1.9.3 OS X problem installing

    ruby 1.9.3 OS X problem installing


    hi,

    Anyone can help me out with hints how to install 1.9.3 version of Ruby? I have 1.8.3, but Cmd v4 needs 1.9.3. So I found some articles, some mentions Homebrew, which I have already installed. But for some reason I do not have RVM.
    Any hints how can I do this clearly, how to get rid of old Ruby 1.8.3?

    thanks any ideas appreciated

Turkiyenin en sevilen filmlerinin yer aldigi xnxx internet sitemiz olan ve porn sex tarzi bir site olan mobil porno izle sitemiz gercekten dillere destan bir durumda herkesin sevdigi bir site olarak tarihe gececege benziyor. Sitenin en belirgin ozelliklerinden birisi de Turkiyede gercekten kaliteli ve muntazam, duzenli porno izle siteleri olmamasidir. Bu yuzden iste. Ayrica en net goruntu kalitesine sahip adresinde yayinlanmaktadir. Mesela diğer sitelerimizden bahsedecek olursak, en iyi hd porno video arşivine sahip bir siteyiz. "The Best anal porn videos and slut anus, big asses movies set..." hd porno faketaxi