1. #1
    Sencha User
    Join Date
    Mar 2013
    Posts
    1
    Vote Rating
    0
    adri535 is on a distinguished road

      0  

    Default 4.0.7 to 4.2.0 upgrade

    4.0.7 to 4.2.0 upgrade


    Hi,

    I need to upgrade an Extjs 4.0.7 to a 4.2.0 application,
    unfortunately i cannot find any documentation on how to achieve this.
    Can someone give me some straightforward guidelines to do this?
    (Started developing with extjs some weeks ago, so I'm fairly new to the whole Sencha -exjts framework, community, ..)

    thx!

  2. #2
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    8,868
    Vote Rating
    438
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      1  

    Default


    This would be difficult to determine as it depends on your code and how it is implemented.

    There are no guidelines available for 4.0 -> 4.2 upgrades that I am aware of.

    I would recommend using ext-dev.js (or ext-all-dev.js) and have a look at the console to see what errors/warnings are present. These need to be cleared before anything else.

    One of the biggest problems that users face in moving away from 4.0.x is bad layout issues.

    The first comment is that .. my layout does not work! It's broken.. the truth is that 4.0 allowed a lot of crappy/incorrect layouts and they are not allowed in 4.1/4.2 versions.

    Youe move could be easy, or take some investigation, but well worth the effort.

    Scott.

  3. #3
    Sencha User
    Join Date
    Oct 2013
    Posts
    8
    Vote Rating
    -5
    andersoninfidelitysencha can only hope to improve

      0  

    Default


    unfortunately, I also doing the upgrade from 4.0.7 to 4.2.1
    the page layout turns such a mass.
    why the new version can't compatile with the old version?
    And they don't provide some guidelines for upgrading, what a sigh.

  4. #4
    Sencha - Support Team scottmartin's Avatar
    Join Date
    Jul 2010
    Location
    Houston, Tx
    Posts
    8,868
    Vote Rating
    438
    scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future scottmartin has a brilliant future

      0  

    Default


    If you are having problems with getting your layouts to work, then I would recommend using Sencha Architect to design your layout as you need .. and then use that code.

    4.07 allowed for a lot of bad behavior in layouts.

    There is no layout that cannot be duplicated in 4.2.x with the proper setup.

    Scott.

  5. #5
    Sencha User
    Join Date
    Oct 2013
    Posts
    8
    Vote Rating
    -5
    andersoninfidelitysencha can only hope to improve

      0  

    Default


    a lot of users gonna lost the interest in extjs upgrade, means your new products, if there is any concrete upgrade guides helping them archieve their upgrade.
    4.07 allowed for a lot of bad behavior in layouts. sure, that's ok. at least, the application developed with 4.0.7 can live well in the environment of extjs 4.2.1, right?

  6. #6
    Sencha User
    Join Date
    Oct 2013
    Posts
    8
    Vote Rating
    -5
    andersoninfidelitysencha can only hope to improve

      -3  

    Default


    NO help. thx.

  7. #7
    Sencha User
    Join Date
    Mar 2013
    Posts
    4
    Vote Rating
    0
    uma@12345 is on a distinguished road

      0  

    Default


    can anyone please tell me how to upgrade my existing java application using extjs4.1.3 to extjs4.2...please guide me with the steps that would be very grateful..

  8. #8
    Sencha User
    Join Date
    Mar 2013
    Posts
    1
    Vote Rating
    0
    hsaraf1 is on a distinguished road

      0  

    Default Facing problems while upgrading from 4.0.7 to 4.2.0

    Facing problems while upgrading from 4.0.7 to 4.2.0


    Hi,

    I am trying to upgrade from 4.0.7 to 4.2.0. Can you please guide me to the document which have the steps for the same because i am facing lot of issue. For eg :
    in 4.0.7 for blur and focus event we use to have method signature as function(field, eOpts) but after upgrading to 4.2.x the signature have changed to function(component, e, eOpts). Is there any tool to identify this discrepancies ? or we have manually test the application and find this issue.
    Appreciate your quick reply.